Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#2015 closed defect (not our bug)

"Error starting the tunnel ...: null" error messages on 0.9.30-17-rc

Reported by: slumlord Owned by:
Priority: minor Milestone: undecided
Component: unspecified Version: 0.9.30
Keywords: hidden.service, tunnel, error Cc:
Parent Tickets: Sensitive: no

Description

Immediately after an update to 0.9.30-17-rc there are messages:

Starting tunnel I2P HTTP Proxy...
Error starting the tunnel I2P HTTP Proxy: null

in logs:

ERROR [P HTTP Proxy] i2p.i2ptunnel.TunnelController: Error starting the tunnel I2P HTTP Proxy
     java.lang.UnsupportedOperationException
     at net.i2p.client.streaming.impl.I2PSocketManagerFull.setName(I2PSocketManagerFull.java:161)
     at net.i2p.i2ptunnel.I2PTunnelClientBase.buildSocketManager(I2PTunnelClientBase.java:440)
     at net.i2p.i2ptunnel.I2PTunnelClientBase.buildSocketManager(I2PTunnelClientBase.java:393)
     at net.i2p.i2ptunnel.I2PTunnelClientBase.getSocketManager(I2PTunnelClientBase.java:307)
     at net.i2p.i2ptunnel.I2PTunnelClientBase.getSocketManager(I2PTunnelClientBase.java:253)
     at net.i2p.i2ptunnel.I2PTunnelClientBase.verifySocketManager(I2PTunnelClientBase.java:237)
     at net.i2p.i2ptunnel.I2PTunnelClientBase.startRunning(I2PTunnelClientBase.java:526)
     at net.i2p.i2ptunnel.I2PTunnelHTTPClient.startRunning(I2PTunnelHTTPClient.java:318)
     at net.i2p.i2ptunnel.I2PTunnel.runHttpClient(I2PTunnel.java:976)
     at net.i2p.i2ptunnel.TunnelController.startHttpClient(TunnelController.java:439)
     at net.i2p.i2ptunnel.TunnelController.doStartTunnel(TunnelController.java:398)
     at net.i2p.i2ptunnel.TunnelController.startTunnel(TunnelController.java:355)
     at net.i2p.i2ptunnel.TunnelController$1.run(TunnelController.java:335)
     at java.lang.Thread.run(Thread.java:745)
     at net.i2p.util.I2PThread.run(I2PThread.java:103)

system details:

I2P version:	0.9.30-17-rc
Java version:	Oracle Corporation 1.8.0 (OpenJDK Runtime Environment 1.8.0)
Wrapper version:	3.5.30
Server version:	9.2.21.v20170120
Servlet version:	Jasper JSP 2.3 Engine
JSTL version:	standard-taglib 1.2.0
Platform:	Linux amd64 4.4.67-13.pvops.qubes.x86_64
Jcpuid version:	3
Processor:	Ivy Bridge (coreisbr)
Jbigi:	Locally optimized library libjbigi-linux-coreisbr_64.so loaded from file
Jbigi version:	3
GMP version:	6.0.0
Encoding:	UTF-8
Charset:	UTF-8

Subtickets

Change History (4)

comment:1 Changed 2 years ago by zzz

Resolution: not our bug
Status: newclosed

Looks bogus. No exception is thrown from setName, line numbers don't match, only UnsupportedOperationExceptions? are in deprecated constructor and init(). So it "can't happen". Must be a bad build, JVM bug, bad RAM/hardware, or updated jar while JVM was running.

comment:2 Changed 2 years ago by slumlord

Re-tried the upgrade, looks good this time. thanks

comment:3 Changed 2 years ago by slumlord

I see these errors on files transferred from bobthebuilder.i2p,

If I re-run ant updater on the same system with a fresh copy of i2p.i2p, it works fine and I don't see the errors posted above.

comment:4 Changed 2 years ago by slumlord

building without override.properties avoids these errors, fixed from build 100 onwards http://bobthebuilder.i2p/job/i2p.i2p-openjdk-1.8.0_121/100/

Note: See TracTickets for help on using tickets.