Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#2019 closed defect (fixed)

Build error: __TYPE has private access in MD5

Reported by: mhatta Owned by: zzz
Priority: minor Milestone: 0.9.31
Component: apps/console Version: 0.9.30
Keywords: Cc:
Parent Tickets:

Description

I'm trying to build I2P on Debian sid, but gets the following error:

(snip)
[javac] /home/mhatta/work/Debian/i2p/i2p-0.9.30/apps/routerconsole/java/src/net/i2p/router/web/RouterConsoleRunner.java:886: error: TYPE has private access in MD5

[javac] Credential cred = Credential.getCredential(MD5.TYPE + pw);

(snip)

Subtickets

Change History (7)

comment:1 Changed 20 months ago by zzz

  • Component changed from unspecified to apps/console
  • Status changed from new to infoneeded_new

please provide:
command line you used to build
java -version
if trying to build the debian package, the installed jetty package version

comment:2 Changed 20 months ago by mhatta

  • Status changed from infoneeded_new to new

I'm using I2P's Debian tarball (i2p_0.9.30-3ubuntu1), with removing hardening-wrapper from Build-Dep in debian/control (since it doesn't exist anymore in sid).

So the command line is "dpkg-buildpackage -rfakeroot".

java -version gives:

openjdk version "1.8.0_131"
OpenJDK Runtime Environment (build 1.8.0_131-8u131-b11-2-b11)
OpenJDK 64-Bit Server VM (build 25.131-b11, mixed mode)

The version of libjetty9-java is 9.2.22-2. jetty9 or libjetty9-extra-java is not installed.

Please let me know if you need more information.

comment:3 Changed 20 months ago by zzz

  • Milestone changed from undecided to 0.9.31
  • Owner set to zzz
  • Status changed from new to accepted

Confirmed, thanks, they changed it from public to private in 9.2.22 released a month ago, will fix soon.

If there's anything else to be fixed for sid, let us know. Is the hardening-wrapper thing as simple as removing it from the control file, or is there more to do?

Last edited 20 months ago by zzz (previous) (diff)

comment:4 Changed 20 months ago by zzz

Fixed in f1458d62405aa43818ec549654cd0cbadac681a9 0.9.30-20-rc thank you

comment:5 Changed 20 months ago by zzz

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:6 Changed 20 months ago by mhatta

Thanks for fix! I prepared & tested I2P debs, so I'll upload them to the Debian archive soon.

comment:7 Changed 20 months ago by zzz

You mentioned on IRC that you made other changes. Please open a new ticket with a patch of these changes, thanks.

Note: See TracTickets for help on using tickets.