#2033 closed defect (fixed)

trac errors when creating new topic or replying

Reported by: anonymous maybe Owned by: meeh
Priority: major Milestone: undecided
Component: trac Version: 0.9.31
Keywords: Cc: zzz
Parent Tickets: #2020

Description

for new ticket:-

Oops…
Trac detected an internal error:

SMTPRecipientsRefused: {u'maybeanonymous@mail.i2p': (550, '5.1.1 <maybeanonymous@mail.i2p>: Recipient address rejected: User unknown in virtual mailbox table\n5.1.1 Mail rejected, check syslog from time (Aug 14 23:30:01), client (91.242.200.115)'), u'anonimal@mail.i2p': (550, '5.1.1 <anonimal@mail.i2p>: Recipient address rejected: User unknown in virtual mailbox table\n5.1.1 Mail rejected, check syslog from time (Aug 14 23:30:01), client (91.242.200.115)'), u'zzz@mail.i2p': (550, '5.1.1 <zzz@mail.i2p>: Recipient address rejected: User unknown in virtual mailbox table\n5.1.1 Mail rejected, check syslog from time (Aug 14 23:30:01), client (91.242.200.115)'), u'str4d@mail.i2p': (550, '5.1.1 <str4d@mail.i2p>: Recipient address rejected: User unknown in virtual mailbox table\n5.1.1 Mail rejected, check syslog from time (Aug 14 23:30:01), client (91.242.200.115)')}

There was an internal error in Trac. It is recommended that you notify your local Trac administrator with the information needed to reproduce the issue.

To that end, you could

a ticket.

The action that triggered the error was:

POST: /newticket

for replying:-

Warning: The change has been saved, but an error occurred while sending notifications: {u'maybeanonymous@mail.i2p': (550, '5.1.1 <maybeanonymous@mail.i2p>: Recipient address rejected: User unknown in virtual mailbox table\n5.1.1 Mail rejected, check syslog from time (Aug 14 23:35:08), client (91.242.200.115)'), u'zzz@mail.i2p': (550, '5.1.1 <zzz@mail.i2p>: Recipient address rejected: User unknown in virtual mailbox table\n5.1.1 Mail rejected, check syslog from time (Aug 14 23:35:08), client (91.242.200.115)')} 

Subtickets

Change History (12)

comment:1 Changed 16 months ago by zzz

  • Owner changed from killyourtv to meeh
  • Status changed from new to assigned

Known issue, caused by updates to fix #2020, meeh is working on it

comment:2 Changed 16 months ago by zzz

Just happened to me as well:

Warning: The change has been saved, but an error occurred while sending notifications: {u'maybeanonymous@…': (550, '5.1.1 <maybeanonymous@…>: Recipient address rejected: User unknown in virtual mailbox table\n5.1.1 Mail rejected, check syslog from time (Aug 22 03:40:04), client (91.242.200.115)'), u'zzz@…': (550, '5.1.1 <zzz@…>: Recipient address rejected: User unknown in virtual mailbox table\n5.1.1 Mail rejected, check syslog from time (Aug 22 03:40:04), client (91.242.200.115)')}

comment:3 Changed 16 months ago by zzz

Also, I haven't gotten an email notification from trac in weeks.

comment:4 Changed 16 months ago by zzz

  • Status changed from assigned to testing

Meeh says he fixed it, let's update this ticket to test it.

comment:5 Changed 16 months ago by zzz

  • Parent Tickets set to 2020
  • Status changed from testing to needs_work

Form submissions hang and don't return (though they actually succeeded). Still haven't gotten any emails, including from the above comment.

when returning to the a ticket, I get this:

Warning: The ticket has been created, but an error occurred while sending notifications: SMTP server connection error ([Errno 110] Connection timed out). Please modify [notification] smtp_server or [notification] smtp_port in your configuration.

comment:6 Changed 16 months ago by zzz

and also this:

SMTPRecipientsRefused: {u'zzz@…': (451, '4.3.0 <zzz@…>: Temporary lookup failure'), u'meeh@…': (451, '4.3.0 <meeh@…>: Temporary lookup failure'), u'slumlord@…': (451, '4.3.0 <slumlord@…>: Temporary lookup failure'), u'killyourtv@…': (451, '4.3.0 <killyourtv@…>: Temporary lookup failure')}

comment:7 Changed 16 months ago by meeh

test to trigger mail.

comment:8 Changed 16 months ago by meeh

second test to trigger mail.

comment:9 Changed 16 months ago by meeh

third test to trigger mail.

comment:10 Changed 16 months ago by meeh

Now it should work.. *crossfingers* :)

comment:11 Changed 16 months ago by meeh

The error was caused ubuntu, in their postfix package, they failed to update /etc/postfix/dynamicmaps.cf, which loaded PCRE, which again does the address rewriting so that's why it didn't work by just installing postfix-pcre, even things looks fine.

comment:12 Changed 16 months ago by meeh

  • Resolution set to fixed
  • Status changed from needs_work to closed

Should be resolved now. :)

Note: See TracTickets for help on using tickets.