Opened 18 months ago

Closed 16 months ago

Last modified 16 months ago

#2046 closed defect (fixed)

i2psnark simultaneously shows a torrent as complete & having remaining data to download

Reported by: slumlord Owned by: zzz
Priority: minor Milestone: 0.9.33
Component: apps/i2psnark Version: 0.9.31
Keywords: i2psnark, force.recheck, seed Cc:
Parent Tickets:

Description (last modified by slumlord)

0.9.31-0

  • Download a torrent
  • Pause partially completed torrent
  • Complete download through alternate file transfer method (e.g. rsync)
  • Force recheck
  • Torrent simultaneously shows as Complete but also shows a remaining download amount
  • Resuming torrent results in a continuation of download instead of seeding of torrent

Please see attached file.

Logs do not show any errors related to i2psnark.

Subtickets

Attachments (1)

i2psnark.png (61.3 KB) - added by slumlord 18 months ago.
screenshot of i2psnark

Download all attachments as: .zip

Change History (10)

Changed 18 months ago by slumlord

screenshot of i2psnark

comment:1 Changed 18 months ago by slumlord

  • Description modified (diff)

comment:2 Changed 18 months ago by slumlord

Upgraded to 0.9.31-3, torrent showed as incomplete. Did a force recheck, no change. i2psnark still shows Complete with data remaining.

comment:3 Changed 17 months ago by val

In my case, adding torrent file with already downloaded data causes the following error:

File 'folder/file.txt' exists, but has wrong length (expected 1087 but found 1061) - repairing corruption

While the file is 1087 bytes. The torrent shows like it dot have the last torrent piece.

comment:4 Changed 17 months ago by zzz

  • Milestone changed from undecided to 0.9.33
  • Status changed from new to accepted

didn't get to this for .32, setting milestone as .33

comment:5 Changed 17 months ago by zzz

val, need the .torrent file for that, please attach or link to a postman page or provide magnet

comment:6 Changed 16 months ago by zzz

re: comment 3

  • I got the link to the torrent privately.
  • I verified the file size in the .torrent was 1087 bytes.
  • I conclude that however you got the 'already downloaded data', it was indeed corrupt.
  • I started the torrent in question and waited until the text file was completely downloaded.
  • The length was still 1087, it contained 26 lines of text, and had DOS line endings.
  • With unix line endings, the file would be 26 bytes shorter, or 1061.
  • I conclude that 'val' either got the 'already downloaded data' which had unix line endings, or inadvertently modified the file, perhaps in an editor, by converting the line endings.
  • I did a force recheck, and there were no changes or error reports.

comment:7 Changed 16 months ago by zzz

OP reproduced, testing fix now

comment:8 Changed 16 months ago by zzz

  • Resolution set to fixed
  • Status changed from accepted to closed

in 1d2fff0b9093037c57b1844cea7d87863239c53b 0.9.32-2
Only occurred if torrent had previously run, was previously incomplete,
and was now complete.
Also fixed changed-after-recheck logic to be precise.

comment:9 Changed 16 months ago by slumlord

Hello, had been away from I2P/internet for a bit due to travelling etc.

Glad to see that this has been fixed.

Thank you zzz & val!

Note: See TracTickets for help on using tickets.