#2137 closed defect (fixed)

I2p sidebar status should report "Installing Plugin" not "Updating I2p" when plugins are installed

Reported by: Reportage Owned by: zzz
Priority: trivial Milestone: 0.9.35
Component: apps/console Version: 0.9.32
Keywords: plugin installation Cc:
Parent Tickets:

Description

When a new plugin is in the process of being installed, the sidebar status indicates "Updating I2P" above the progress bar. This should read "Installing Plugin".

Subtickets

Change History (14)

comment:1 Changed 14 months ago by zzz

  • Milestone changed from undecided to 0.9.34
  • Status changed from new to open

comment:2 Changed 14 months ago by zzz

  • Owner changed from str4d to zzz
  • Status changed from open to accepted

comment:3 Changed 14 months ago by zzz

Text in UpdateRunner? and UpdateHandler? was changed very early in the 0.9.33 cycle from the generic "Updating" to the more specific "Updating I2P". However the UpdateRunner? class is extended by all the other runners.

UpdateRunner?.bytesTransferred() says subclasses should override but not all do. Review and implement overrides where necessary.

comment:4 Changed 12 months ago by anonymous maybe

also consider this as related ticket:-

https://github.com/i2p/i2p.i2p-bote/issues/102

comment:5 Changed 12 months ago by zzz

  • Milestone changed from 0.9.34 to 0.9.35

comment:6 Changed 11 months ago by zzz

  • Resolution set to fixed
  • Status changed from accepted to closed

In 0fd45704b7ec1be676ad08886d451e3c63e9d525 0.9.34-3

comment:7 Changed 11 months ago by Reportage

When a plugin update check is initiated, sidebar still reports "Updating I2P"; "Checking for updates" would probably be more accurate, and would also cover the check for news/i2p updates which should also be indicated in the sidebar for consistency.

In the event that no updates are found, the sidebar notification is a bit too persistent and shouldn't be displayed for more than a couple of minutes. In the event that updates are found, perhaps a 5 minute display window would be better.. iirc, the notifications are displayed for 20 minutes, which to my mind is overkill.

comment:8 Changed 11 months ago by Reportage

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:9 Changed 11 months ago by zzz

ok will have to figure out where that's coming from

comment:10 Changed 11 months ago by zzz

What's the action that gets you the "Updating I2P" message? Update/check/install on a single plugin, or the update all plugins button, or?

comment:11 Changed 11 months ago by zzz

  • Status changed from reopened to infoneeded

Can't reproduce and don't see where in the code it's coming from.

comment:12 Changed 11 months ago by Reportage

  • Status changed from infoneeded to open

'Update All Installed Plugins' plugins generates an H3 reading 'I2P Update', as does checking for updates for individual plugins. This should probably read "Checking for updates". I think the 'Updating I2P' H3 is displayed when there are updates available for any of the installed plugins, during the download.

comment:13 Changed 10 months ago by zzz

ok so you're not seeing 'Updating I2P' in the sidebar update section (as you said in comment 7) - that's what I thought I fixed when I closed the ticket in comment 5.

Your issue is now that the sidebar update section, when present, has the h3 header 'I2P Update' no matter what the type of update. That's different text from what I was looking for, that's why I couldn't find it. This section is shown, with the same h3, whenever there is any text to be displayed from the update subsystem. It could be that an update is available, or in progress, or completed. So 'Checking for updates' wouldn't work for the h3.

I can't change the h3 based on what's happening. It's a generic summary bar section header. I could change it from 'I2P Update' to 'Update Status'... maybe that's better, maybe not. On /configsidebar, the section is called 'Update Status' already, so it makes sense to change the h3 to match.

comment:14 Changed 10 months ago by zzz

  • Resolution set to fixed
  • Status changed from open to closed

Changed h3 to 'Update Status' in 9cabeeca878d863b28c5c8508b945dc2adfe75cc 0.9.34-12

Note: See TracTickets for help on using tickets.