#2139 closed defect (fixed)

Susimail: Should not reformat mail; "no charset found" error + attachment fail

Reported by: Reportage Owned by:
Priority: blocker Milestone: 0.9.33
Component: apps/susimail Version: 0.9.32
Keywords: Susimail reformatting, "no charset found" Cc:
Parent Tickets: Sensitive: no

Description

I2P: 0.9.32-23-rc Platform: Linux 4.14

Recent changes to Susimail now reformat incoming mails according to line length, leading to display breakage when line breaks are introduced. Susimail should respect the format of mails and not attempt to reformat.

Additionally, mails created in Susimail (with attachments?) now generate a "Warning: no charset found, fallback to US-ASCII." error which results in the attachment being embedded in the mail and not as an attachment.

Subtickets

Attachments (2)

susimail_cropping.png (15.6 KB) - added by Reportage 21 months ago.
Cropping of e-mail body in Susimail
susimail_attachment_fail.png (56.3 KB) - added by Reportage 21 months ago.
Susimail attachment

Download all attachments as: .zip

Change History (6)

comment:1 Changed 21 months ago by Reportage

Priority: majorblocker

comment:2 Changed 21 months ago by zzz

re: reformatting and breakage, please send or forward examples or screenshots to me at zzz@… or attach here

re: no charset warning, is that on adding the attachment, or sending the mail, or receiving the mail?
Is it related to a particular type of attachment?

Also please provide full version info from top of /logs

Changed 21 months ago by Reportage

Attachment: susimail_cropping.png added

Cropping of e-mail body in Susimail

comment:3 Changed 21 months ago by Reportage

I2P: 0.9.32-23-rc Wrapper: 3.5.30
Platform: Linux amd64 4.14.0-16-generic
Java: Oracle Corporation 1.8.0_151
JSTL: standard-taglib 1.2.0 Encoding: UTF-8 Charset: UTF-8
Browser: Firefox 57.01

The pre-formatted text in the screenshot had no line breaks.

Re: charset warning, in the screenshot the warning was generated on receipt of a test e-mail sent from Susimail, in this instance without an attachment.

Changed 21 months ago by Reportage

Susimail attachment

comment:4 Changed 21 months ago by zzz

Resolution: fixed
Status: newclosed

Thanks for the screenshots, that made it a lot easier. Reproduced here.
There was an extra CRLF before the MIME-Version header, so that and subsequent headers became part of the body. So the Content-Type and Content-Transfer-Encoding headers weren't seen, and nothing was decoded - causing both the encoding issues in the OP.
Caused by my encoding fix for subject header, which added a CRLF where there wasn't one before.
Terrible job by me not finding this in testing.
Fixed in 51c2ea9258f3502b4d630202c2eaa802edb0287c 0.9.32-24-rc

Note: See TracTickets for help on using tickets.