#2205 closed enhancement (wontfix)

add delete button/feature to susimail

Reported by: anonymous maybe Owned by:
Priority: minor Milestone: n/a
Component: apps/susimail Version: 0.9.34
Keywords: Cc:
Parent Tickets: Sensitive: no

Description (last modified by anonymous maybe)

  • I2P Version and Running Environment
 I2P version:	0.9.34-0-2ubuntu1
Java version:	Oracle Corporation 1.8.0_162 (OpenJDK Runtime Environment 1.8.0_162-8u162-b12-1~deb9u1-b12)
Wrapper version:	3.5.30
Server version:	9.2.21.v20170120
Servlet version:	Jasper JSP 2.3 Engine
JSTL version:	standard-taglib 1.2.5
Platform:	Linux amd64 4.14.18-1.pvops.qubes.x86_64
Jcpuid version:	3
Processor:	Haswell Core i3/i5/i7 model 60 (coreihwl)
Jbigi:	Locally optimized native BigInteger library loaded from file
Jbigi version:	4
GMP version:	6.1.2
Encoding:	UTF-8
Charset:	UTF-8

add a button which users can delete permanently their mails from postman servers. this will save the load on the server and also suit the user need if he doesnt want to continue with it

Subtickets

Change History (8)

comment:1 Changed 17 months ago by zzz

Resolution: not a bug
Status: newclosed

If configuration:

pop3.leave.on.server=false

which has been the default for at least a couple of years, mail is deleted from server after it's downloaded.

If you've changed the setting to true, or perhaps if you were running i2p before we made the change, it may be set to true, and it won't be deleted. In that case, it will be deleted on the server when you delete it locally.

comment:2 Changed 17 months ago by anonymous maybe

Description: modified (diff)
Resolution: not a bug
Status: closedreopened

comment:3 Changed 17 months ago by anonymous maybe

so sorry i didnt meant the emails , i mean the mail itself as an e.g me@… or ..etc.

is to add button or option to delete the entire mail from postman servers.

comment:4 Changed 17 months ago by zzz

I still don't understand what you want. "mail itself" = "email" = "entire mail". Could you please elaborate? Or maybe somebody else understands?

comment:5 Changed 17 months ago by Reportage

At a guess, anonymous maybe is requesting an option to delete the mail account from postman's server http://hq.postman.i2p/?page_id=20. If that's viable, would it also make sense to also provide an option within the Susimail UI to create an I2PMail account (with embedded TOS)?

comment:6 Changed 17 months ago by slumlord

Yeah, as Reportage said, this is likely about mail accounts.

comment:7 Changed 17 months ago by anonymous maybe

yep its about mail accounts

comment:8 Changed 17 months ago by zzz

Milestone: undecidedn/a
Resolution: wontfix
Status: reopenedclosed
Type: defectenhancement
Version: 0.9.330.9.34

Thanks for the clarifications.
There is no way via POP3 to delete an account.
If you click on the 'create account' button on the susimail login page, you will see a link to 'deleting a mailbox' on the right hand side on hq.postman.i2p which leads you to http://hq.postman.i2p/?page_id=20 . It's really easy to figure out and there's no need to make it easier, and no way to make it easier.
Not going to do it.

Note: See TracTickets for help on using tickets.