Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#2222 closed defect (not a bug)

Out of memory error causing router to crash

Reported by: Xeyed1 Owned by:
Priority: minor Milestone: undecided
Component: unspecified Version: 0.9.34
Keywords: Out of memory error router crash Cc: xeyed1@…
Parent Tickets: Sensitive: no

Description

system is debian stretch amd64

I searched for tickets that mentioned 'out of memory error', 'router shutdown' and 'router crash'. I did not see anything that seemed directly relevant to this problem.

I started noticing crashes with I2P 0.9.33 in January. They were infrequent and I was not sure that it was I2P related.

With 0.9.34 crashes are more frequent and the frequency seems to be increasing. For the crash that generated this error report the system was probably up less than 30 minutes. It was running around 10 torrents in I2PSnark, 2 hops per tunnel. This was the first time I noticed an Error report. It reports an Out of Memory Error and is included below.

I have tried monitoring the system using the Gnome System Monitor program to try and see what may be contributing factors. It shows that I seldom use more than 10% of RAM and usually less than half of the available bandwidth. There does not seem to be any correlation between these and router crashes. What does seem to happen consistently is an increase in CPU usage. All cores on the CPU go to about 80% usage and stay that way. Sometimes it will resolve but usually CPU usage stays at 80% until the router crashes and restarts.

The router console seldom reaches its bandwidth limits. Usually it runs at about half of what is available. There does not seem to be a correlation between bandwidth usage and router crashes.

No other processes on the system seem to be affected. When the router restarts I2PSnark needs to be restarted manually and it sets itself and a maximum upload speed of 25Kbps. Manually restarting the router does not change this upload setting and I have to power off the machine and reboot the system to get I2PSnark to not set this upload limit. Otherwise it will stay in this crippled state. Ticket #2120 seems to relate to this in so far as restarting I2P to the previous state would make these crashes less onerous.

The Service (Wrapper)Log suggests 'To prevent future shutdowns, increase wrapper.java.maxmemory' in the file 'wrapper.config', however after looking in /usr/share/i2p, /var/lib/i2p, and in ~/.i2p I was unable to find that file.

Subtickets

Attachments (3)

I2P Version and Running Environment (527 bytes) - added by Xeyed1 16 months ago.
I2P Version and Running Environment
Error Details (3.4 KB) - added by Xeyed1 16 months ago.
Out of Memory Error Details
Service Wrapper Log (21.0 KB) - added by Xeyed1 16 months ago.
Service Wrapper Log

Download all attachments as: .zip

Change History (6)

Changed 16 months ago by Xeyed1

I2P Version and Running Environment

Changed 16 months ago by Xeyed1

Attachment: Error Details added

Out of Memory Error Details

Changed 16 months ago by Xeyed1

Attachment: Service Wrapper Log added

Service Wrapper Log

comment:1 Changed 16 months ago by slumlord

Hi, I'm not familiar with I2P from Debian's package repository but you can look in /etc for an i2p folder and you can also run:

% sudo find / -type f -iname 'wrapper.config'

to search for the file on your system.

I am sure someone who is familiar with Debian can point you to the right directory.

comment:2 Changed 16 months ago by Xeyed1

Cc: xeyed1@… added
Resolution: not a bug
Status: newclosed

Thanks slumlord for the good advice.

I did find wrapper.config in /etc/i2p/, which is not where the error message said to look. I got that from line 238 of the Service Wrapper Log that I included.

238 2018/05/07 03:19:35 | CRIT [P reader ¾] net.i2p.router.Router : To prevent future shutdowns, increase wrapper.java.maxmemory in /usr/share/i2p/wrapper.config

Other documentation mentioned a split installation which lead me to look in /var/lib/i2p, and in ~/.i2p.

Increasing wrapper.java.maxmemory seems to have stopped the router crashes (shutdowns). Oddly though when I set it to 512MB the router console shows that it allocates 3-400MB out of 400+ MB available. When it gets set to 1024MB it only uses 100+MB.

Perhaps the issue now becomes how to change error messages and documentation so that users understand and are able to find and adjust settings.

comment:3 Changed 16 months ago by slumlord

That's a good point, Xeyed1. I will make a ticket to address the issue of error messages referring to an incorrect directory.


Ticket #2223

Last edited 16 months ago by slumlord (previous) (diff)
Note: See TracTickets for help on using tickets.