#2229 closed defect (fixed)

I2PSNARK Disregards download priorities after restart

Reported by: uz-spark Owned by: zzz
Priority: minor Milestone: 0.9.35
Component: apps/i2psnark Version: 0.9.34
Keywords: Cc:
Parent Tickets:

Description

I2PSNARK Disregards download priorities after restart. As is, they're still set but files is downloaded even if set to skip. Applying priority on any file will get priorities for that torrent to function.

Subtickets

Attachments (1)

i2psnark-2229.png (178.5 KB) - added by slumlord 10 months ago.
Files being downloaded after a restart despite having priority set to 'Do Not Download'

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 months ago by zzz

  • Status changed from new to infoneeded_new

Was this a small file (less than or equal to twice the piece size) or a large file?

Note that the first and last piece of a file may be downloaded even if set to skip, because the pieces may overlap with a non-skipped file. As a result, small files may be completely downloaded even if set to skip.

comment:2 Changed 10 months ago by uz-spark

  • Status changed from infoneeded_new to new

Nope, these files definitely are larger than piece size, and getting downloaded continuously until manual priorities reset. Will try clean install on another machine to exclude possible problems with my setup.

comment:3 Changed 10 months ago by uz-spark

Just tried on clean install, same behavior.

  1. Set 'skip' priority on all files in torrent, so torrent will not be downloaded at all.
  2. Restart either I2PSnark or I2P router completely.
  3. Priorities in torrent is set as before but torrent is downloading now, and torrent info page shows 'remaining' equal to 'size', despite all files are skipped.
  4. Set priority (another or the same) on any file in torrent and that torrent is now downloading according to priorities. Each torrent needs that procedure after restart.
Last edited 10 months ago by uz-spark (previous) (diff)

comment:4 follow-up: Changed 10 months ago by zzz

Unable to reproduce here yet. Do you have auto-start enabled in snark config?

comment:5 in reply to: ↑ 4 Changed 10 months ago by uz-spark

Replying to zzz:

Unable to reproduce here yet. Do you have auto-start enabled in snark config?

Yes.

Last edited 10 months ago by uz-spark (previous) (diff)

Changed 10 months ago by slumlord

Files being downloaded after a restart despite having priority set to 'Do Not Download'

comment:6 Changed 10 months ago by zzz

  • Milestone changed from undecided to 0.9.35
  • Status changed from new to accepted

reproduced here with autostart on

comment:7 Changed 10 months ago by slumlord

Reproduced here, see screenshot.
magnet:?xt=urn:btih:ea74c208e8ba7801be1314100f454332215f24fb was the test torrent.

comment:8 Changed 10 months ago by zzz

  • Resolution set to fixed
  • Status changed from accepted to closed

When autostart enabled, torrent was started before priorities were loaded from the stored config.
Fixed in 422c7dc98959b2ed69cc4cfcf1e6793d4ff2c848 0.9.34-18

Note: See TracTickets for help on using tickets.