Opened 12 months ago

Last modified 12 months ago

#2231 reopened defect

Reseeding does not increase number of known routers after 1 hour of uptime

Reported by: Reportage Owned by:
Priority: minor Milestone: undecided
Component: api/utils Version: 0.9.34
Keywords: reseeding Cc:
Parent Tickets:

Description

Successfully reseeding, either via urls or file, does not add additional routers to the network db after about 1 hour of uptime. Logs/sidebar indicate a successful reseed, but there is no increment to the number of known peers.

Subtickets (add)

Change History (7)

comment:1 Changed 12 months ago by echelon

  • Status changed from new to infoneeded_new

Hi

any stats of active peers, active tunnels?

echelon

comment:2 Changed 12 months ago by Reportage

  • Status changed from infoneeded_new to new

State of active peers and tunnels is fairly normal. Occasionally after the 1 hour window a reseed will be successful, but more often than not it reports success but doesn't increment the Known peers.

comment:3 Changed 12 months ago by echelon

Ok, so if the active peers and tunnels are normal, reseed job is done.
No need to get more peers.
It is not the job of reseed to get more peers after router started up.

Last edited 12 months ago by echelon (previous) (diff)

comment:4 Changed 12 months ago by echelon

  • Resolution set to not a bug
  • Status changed from new to closed

comment:5 Changed 12 months ago by Reportage

  • Resolution not a bug deleted
  • Status changed from closed to reopened

This is a bug, not a feature. There is nothing in the codebase that expressly prevents a reseed from occurring when there are more than x peers in the NetDB. This bug also appears to affect acquisition of new router infos from other peers, in addition to inhibiting the acquisition of peers from a manual reseed, either from hosts or from file.

Unless and until you've reviewed the source for the potential issue, please don't close this bug on a whim. Thanks.

comment:6 Changed 12 months ago by echelon

  • Priority changed from major to obsolete

There is a limit of ~20 active peers which prevents reseeding button to appear, as reseeding did went well and I2P is active. No need to reseed again.
Thats not a bug, thats a feature.
And thats for a reason of security and preventing a sybil/enumberation attack.

If there is a bug later on preventing addding more peers via a reseeding file, it is quite not important, as a user does not see this at all, neither use the reseed at all.

Best way would be to disable reseed feature on >20 active peers and not only hide the button to reseed.

comment:7 Changed 12 months ago by Reportage

  • Priority changed from obsolete to minor
Note: See TracTickets for help on using tickets.