#2282 closed defect (not a bug)

plugin update check up should be after successful connection

Reported by: anonymous maybe Owned by: zzz
Priority: minor Milestone: undecided
Component: apps/plugins Version: 0.9.35
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

when i started i2p , it checks for updates for the installed plugins. but the problem is that the check up starting while there is not yet even a tunnel connection or successfully connected through tunnels.

please fine the attachment image for more clarification.

  • I2P Version and Running Environment
 I2P version:	0.9.35-0-1ubuntu1
Java version:	Oracle Corporation 9-Debian (OpenJDK Runtime Environment 9-Debian+0-9b181-4bpo91)
Wrapper version:	3.5.30
Server version:	9.2.21.v20170120
Servlet version:	Jasper JSP 2.3 Engine
JSTL version:	standard-taglib 1.2.5
Platform:	Linux amd64 4.14.41-1.pvops.qubes.x86_64
Processor:	Haswell Core i3/i5/i7 model 60 (coreihwl)
JBigI status:	Locally optimized native BigInteger library loaded from file
GMP version:	6.1.2
JBigI version:	4
JCpuId version:	3
Encoding:	UTF-8
Charset:	UTF-8
Built By:	Undefined

Subtickets

Attachments (1)

pluginupdate.png (47.6 KB) - added by anonymous maybe 14 months ago.

Download all attachments as: .zip

Change History (2)

Changed 14 months ago by anonymous maybe

Attachment: pluginupdate.png added

comment:1 Changed 14 months ago by zzz

Resolution: not a bug
Status: newclosed

That's just the user message. Internally, it's waiting for the tunnels, of course.

Note: See TracTickets for help on using tickets.