Opened 15 months ago

Closed 3 months ago

#2283 closed defect (worksforme)

ERROR [P HTTP Proxy] .i2ptunnel.I2PTunnelClientBase: Unable to build tunnels for the client

Reported by: anonymous maybe Owned by:
Priority: trivial Milestone: undecided
Component: unspecified Version: 0.9.35
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

freshly upgraded i2p to 0.9.35 , and i got these errors:

  • I2P Version and Running Environment
 I2P version:	0.9.35-0-1ubuntu1
Java version:	Oracle Corporation 9-Debian (OpenJDK Runtime Environment 9-Debian+0-9b181-4bpo91)
Wrapper version:	3.5.30
Server version:	9.2.21.v20170120
Servlet version:	Jasper JSP 2.3 Engine
JSTL version:	standard-taglib 1.2.5
Platform:	Linux amd64 4.14.41-1.pvops.qubes.x86_64
Processor:	Haswell Core i3/i5/i7 model 60 (coreihwl)
JBigI status:	Locally optimized native BigInteger library loaded from file
GMP version:	6.1.2
JBigI version:	4
JCpuId version:	3
Encoding:	UTF-8
Charset:	UTF-8
Built By:	Undefined
  • Router Logs
    6/29/18, 9:53:08 AM ERROR [P HTTP Proxy] .i2ptunnel.I2PTunnelClientBase: Unable to build tunnels for the client, retrying in 20 seconds
         net.i2p.client.I2PSessionException: [GOTDATE shared clients #64485]: Failed to build tunnels
         at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:731)
         at net.i2p.i2ptunnel.I2PTunnelClientBase.connectManager(I2PTunnelClientBase.java:462)
         at net.i2p.i2ptunnel.I2PTunnelClientBase.verifySocketManager(I2PTunnelClientBase.java:242)
         at net.i2p.i2ptunnel.I2PTunnelClientBase.startRunning(I2PTunnelClientBase.java:528)
         at net.i2p.i2ptunnel.I2PTunnelHTTPClient.startRunning(I2PTunnelHTTPClient.java:325)
         at net.i2p.i2ptunnel.I2PTunnel.runHttpClient(I2PTunnel.java:976)
         at net.i2p.i2ptunnel.TunnelController.startHttpClient(TunnelController.java:476)
         at net.i2p.i2ptunnel.TunnelController.doStartTunnel(TunnelController.java:437)
         at net.i2p.i2ptunnel.TunnelController.startTunnel(TunnelController.java:394)
         at net.i2p.i2ptunnel.TunnelController$1.run(TunnelController.java:374)
         at java.base/java.lang.Thread.run(Thread.java:844)
         at net.i2p.util.I2PThread.run(I2PThread.java:103)
         Caused by: java.io.IOException: No tunnels built after waiting 5 minutes. Your network connection may be down, or there is severe network congestion.
         at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:686)
         ... 11 more
    6/29/18, 9:50:39 AM ↓↓↓ 2 similar messages omitted ↓↓↓
    6/29/18, 9:50:39 AM WARN [luginStarter] rg.eclipse.jetty.server.Server: EXCEPTION : java.lang.IllegalArgumentException: File not resolvable or incompatible with URLClassloader: jar:file:/home/user/.i2p/plugins/i2pbote/console/webapps/i2pbote.war!/WEB-INF/lib/tomcat-jsp-api-8.5.23.jar

Subtickets

Change History (3)

comment:1 Changed 14 months ago by Eche|on

Priority: minortrivial
Status: newinfoneeded_new

hey

looks ll good so far? Just this once occurance or does it happen more often?

echelon

comment:2 Changed 10 months ago by anonymous maybe

Status: infoneeded_newnew

once only occurred

comment:3 Changed 3 months ago by anonymous maybe

Resolution: worksforme
Sensitive: unset
Status: newclosed

closing as it didnt appeared again.

Note: See TracTickets for help on using tickets.