Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#2300 closed defect (fixed)

Summary Bar in Console - Router info box not formatted properly 0.9.36-0-2ubuntu1

Reported by: Xeyed1 Owned by: zzz
Priority: minor Milestone: 0.9.37
Component: package/debian Version: 0.9.36
Keywords: router console summary bar display Cc: mhatta
Parent Tickets:

Description

After upgrading to 0.9.36-0-2ubuntu1-2ubuntu1

The text in the Router Info box of the Summary Bar does not display properly. The text overflows the right hand margin of the bounding box. Other boxes display correctly.

Debian Stretch 9.0.8
Firefox browser

Subtickets

Change History (7)

comment:1 Changed 9 months ago by zzz

  • Component changed from unspecified to package/debian
  • Milestone changed from undecided to 0.9.37
  • Status changed from new to infoneeded_new

Did you get it from our deb.i2p2.de/no repo or from official stretch?
What text is overflowing? is -2ubunutu1-2ubuntu1 really there twice?
I think that's a bug in the build script that makes it do that.

comment:2 Changed 9 months ago by Xeyed1

  • Status changed from infoneeded_new to new

repository is

https://deb.i2p2.de/ stretch main

is -2ubunutu1-2ubuntu1 really there twice?

Yes it shows up twice

What text is overflowing?

The text that is overflowing is in the advanced "Router Info" box.
See below for the actual text.
The usual "Router Info" box displays properly.
Sorry I should have mentioned that in the original post.

Version: 0.9.36-0-2ubuntu1-2ubuntu1
Uptime: 2 days
Clock Skew: 56 ms
Memory: 90 / 910 MiB

comment:3 Changed 9 months ago by zzz

  • Cc mhatta added
  • Owner set to zzz
  • Status changed from new to accepted

Thanks.

There's a sed script in debian/rules that sticks the version suffix into RouterVersion?.java.
Not sure if it's going in twice on the first run, or it's a side effect of the -1ubuntu1 build breaking this time, and I had to do a -2ubuntu1, and it got doubled that way.

ifeq "$(findstring deb,$(shell grep 'deb' $(ROUTERVERSION)))" ""
	sed -e "s/\(.*EXTRA\ =\ \)[^ ]*\"\(.*\)\"/\1\"\2-$$EXTRAPREFIX$$DEBIANVERSION\"/" < $(ROUTERVERSION) > $(ROUTERVERSION).tmp
	mv -f $(ROUTERVERSION).tmp $(ROUTERVERSION)
else
	@echo "Already found deb in version, not doing anything"
endif

cc: mhatta to help me figure it out

comment:4 Changed 9 months ago by zzz

There's code in the rules file to save the old RouterVersion?.java and restore it, but it's not happening, at least the way I do the builds. I'm going to remove the backslash-2 in the sed line and that will fix it for sure.

comment:5 Changed 9 months ago by zzz

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in f7b28892c564f2b360f9f9dc8a8ad11c760b347a to be 0.9.36-4, should prevent this happening in the future.

comment:6 Changed 9 months ago by Xeyed1

Thanks for the fix on the repeating text. ie. -2ubunutu1-2ubuntu1

I tried looking at your changes to the sed script. Not really familiar with sed or the java code but it does not look to me that this addresses the original formatting issue.

The text that is overflowing is in the advanced "Router Info" box.
See below for the actual text.
The usual "Router Info" box displays properly.
Sorry I should have mentioned that in the original post.

The text that is overflowing is the last 2 or 3 characters of each of the following lines.

Version: 0.9.36-0-2ubuntu1-2ubuntu1
Uptime: 2 days
Clock Skew: 56 ms
Memory: 90 / 910 MiB

I can try to install the 0.9.36-4 to test if you think this has been addressed.

comment:7 Changed 9 months ago by zzz

The bug was caused by repeated builds. If you only build it once, you wouldn't see it doubled. If you built it 3 times, it got tripled. Maybe if you built it differently, you wouldn't see it at all. I did do tests to make sure it wasn't doubled any more. You can build and test it if you like.

I think the way the table is in the html, the long version caused the other lines to overflow also, as they are all right-justified. Once the version isn't so long, nothing should overflow.

Note: See TracTickets for help on using tickets.