Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#2307 closed defect (fixed)

Build hang

Reported by: zzz Owned by: zzz
Priority: blocker Milestone: 0.9.37
Component: package/debian Version: 0.9.36
Keywords: Cc: Masayuki Hatta
Parent Tickets: Sensitive: no

Description

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=908884

Caused by this change in Tomcat 8.5.33:
https://bz.apache.org/bugzilla/show_bug.cgi?id=53492

I have a workaround on our side but haven't checked it in yet, I was hoping tomcat would fix it. But stretch-backports now has 8.5.33, and buster and sid have 8.5.34 (same behavior as 33) so we need to fix it.

Will post the fix here as a diff so debian/ubuntu maintaners can pick it up.

Subtickets

Attachments (1)

2307-fix.diff (6.8 KB) - added by zzz 13 months ago.

Download all attachments as: .zip

Change History (5)

Changed 13 months ago by zzz

Attachment: 2307-fix.diff added

comment:1 Changed 13 months ago by zzz

Resolution: fixed
Status: newclosed

To elaborate, with new the multithreaded JspC implementation in Tomcat 8.5.33, invoking it from an ant script as we do (with fork=true), the JVM never exits, presumably because the Tomcat thread pool is not marked as daemon. Not sure if that was their intent, or they just didn't consider our use case. Worked around by adding a helper class on our side that exits the JVM on JspC completion.

Workaround on our side above, or see git version at
https://github.com/i2p/i2p.i2p/commit/6b53a4fac483c092e498acb2b5b79ac1bc622a3a

Should apply cleanly as a backport to 0.9.36-0, but haven't tried or tested it there.

Fixed in 64d9c9640921b0387be8cee85923553b6f49821a to be 0.9.36-4

comment:2 Changed 13 months ago by Masayuki Hatta

The workaround is applied and works in Debian 0.9.36-2.

comment:3 Changed 13 months ago by zzz

Apache bug: https://bz.apache.org/bugzilla/show_bug.cgi?id=62674

Thanks mhatta for applying the workaround and for commenting on the apache bug to point them here.

comment:4 Changed 13 months ago by zzz

Tomcat fix will be in 8.5.35.

Note: See TracTickets for help on using tickets.