Opened 11 months ago

Last modified 11 months ago

#2325 new defect

i2p package with down-rev libjbigi-jni

Reported by: zzz Owned by: zzz
Priority: minor Milestone: undecided
Component: package/debian Version: 0.9.37
Keywords: Cc: Masayuki Hatta
Parent Tickets: Sensitive: no

Description

In our deb repo, the libjbigi-jni packages for many architectures are out of date, as we no longer do the builds ourselves (we simply copy them from launchpad, which only supports i386 and amd64).

But the i2p debian/control file essentially requires all sub-packages including libjbigi-jni to be at the same rev. Is there a way to allow a down-rev subpackage, or to make the subpackage optional? This would allow e.g. RPi armhf updates from our repo.

Subtickets

Change History (2)

comment:1 Changed 11 months ago by Masayuki Hatta

I'm not sure what you want…do you want to allow users to install different versions of i2p and libjbigi-jni at the same time? (e.g. i2p 0.9.37-1 and libjbigi-jni 0.9.35-1 or such). If so, simply removing "${misc:Depends}" from Depends of the libjbigi-jni entry in debian/control will remove versioned dependency of libjbigi-jni to i2p-router.

comment:2 Changed 11 months ago by zzz

yes, I want it it to get the new version of libjbigi-jni if available but not require that the version of libjbigi-jni matches the versions of the other things. I'll give your solution a try, thanks.

Note: See TracTickets for help on using tickets.