#2343 closed defect (not a bug)

IRC Upgrade lead to CRIT [uildExecutor] net.i2p.util.Clock : Large clock shift forward by 5m

Reported by: anonymous maybe Owned by:
Priority: minor Milestone: undecided
Component: api/i2cp Version: 0.9.37
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

It seems after the upgrade happened to irc.00.i2p , the router time skew shifted to 5 minutes. This is dangerous as it will lead to time attack deanonymization. Hope the logs will help:-

  • I2P Version and Running Environment
 I2P version:	0.9.37-0-1ubuntu1
Java version:	Oracle Corporation 9-Debian (OpenJDK Runtime Environment 9-Debian+0-9b181-4bpo91)
Wrapper version:	3.5.30
Server version:	9.2.21.v20170120
Servlet version:	Jasper JSP 2.3 Engine
JSTL version:	standard-taglib 1.2.5
Platform:	Linux amd64 4.14.67-1.pvops.qubes.x86_64
Processor:	Haswell Core i3/i5/i7 model 60 (coreihwl)
JBigI status:	Locally optimized library libjbigi-linux-coreihwl_64.so loaded from file
GMP version:	6.1.2
JBigI version:	4
JCpuId version:	3
Encoding:	UTF-8
Charset:	UTF-8
Built By:	Undefined
  • Critical Logs
    10/19/18, 2:40:47 AM CRIT [uildExecutor] net.i2p.util.Clock : Large clock shift forward by 5m
  • Router Logs
    10/19/18, 2:40:47 AM ERROR [SED Irc2P]: ] lient.impl.I2PSessionMuxedImpl: [CLOSED Irc2P]: Error reconnecting on attempt 1
         net.i2p.client.I2PSessionException: [GOTDATE Irc2P #40072]: Failed to build tunnels
         at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:731)
         at net.i2p.client.impl.I2PSessionImpl.reconnect(I2PSessionImpl.java:1335)
         at net.i2p.client.impl.I2PSessionImpl2.reconnect(I2PSessionImpl2.java:490)
         at net.i2p.client.impl.DisconnectMessageHandler$Reconnector.run(DisconnectMessageHandler.java:51)
         at java.base/java.lang.Thread.run(Thread.java:844)
         at net.i2p.util.I2PThread.run(I2PThread.java:103)
         Caused by: java.io.IOException: No tunnels built after waiting 5 minutes. Your network connection may be down, or there is severe network congestion.
         at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:686)
         ... 5 more
    10/19/18, 2:35:36 AM ERROR [nt Runner 34] .i2ptunnel.I2PTunnelClientBase: Unable to build tunnels for the client, retrying in 20 seconds
         net.i2p.client.I2PSessionException: [CLOSED Irc2P]: Failed to build tunnels
         at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:731)
         at net.i2p.i2ptunnel.I2PTunnelClientBase.connectManager(I2PTunnelClientBase.java:462)
         at net.i2p.i2ptunnel.I2PTunnelClientBase.verifySocketManager(I2PTunnelClientBase.java:242)
         at net.i2p.i2ptunnel.I2PTunnelClientBase.createI2PSocket(I2PTunnelClientBase.java:651)
         at net.i2p.i2ptunnel.I2PTunnelIRCClient.clientConnectionRun(I2PTunnelIRCClient.java:136)
         at net.i2p.i2ptunnel.I2PTunnelClientBase$BlockingRunner.run(I2PTunnelClientBase.java:830)
         at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1167)
         at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:641)
         at java.base/java.lang.Thread.run(Thread.java:844)
         Caused by: java.io.IOException: Disconnected from router while waiting for tunnels
         at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:694)
         ... 8 more
    10/19/18, 2:35:13 AM WARN [uter Restart] net.i2p.router.Router : Restart complete
    10/19/18, 2:35:13 AM WARN [uter Restart] net.i2p.router.Router : Restarting the client manager
    10/19/18, 2:35:13 AM WARN [uter Restart] net.i2p.router.Router : Restarting the tunnel manager
    10/19/18, 2:35:13 AM WARN [uter Restart] net.i2p.router.Router : Restarting the comm system
    10/19/18, 2:35:06 AM ERROR [nt Runner 34] .i2ptunnel.I2PTunnelClientBase: Unable to build tunnels for the client, retrying in 20 seconds
         net.i2p.client.I2PSessionException: Router client manager is shut down
         at net.i2p.router.client.ClientManager.internalConnect(ClientManager.java:211)
         at net.i2p.router.client.ClientManagerFacadeImpl.connect(ClientManagerFacadeImpl.java:265)
         at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:614)
         at net.i2p.i2ptunnel.I2PTunnelClientBase.connectManager(I2PTunnelClientBase.java:462)
         at net.i2p.i2ptunnel.I2PTunnelClientBase.verifySocketManager(I2PTunnelClientBase.java:242)
         at net.i2p.i2ptunnel.I2PTunnelClientBase.createI2PSocket(I2PTunnelClientBase.java:651)
         at net.i2p.i2ptunnel.I2PTunnelIRCClient.clientConnectionRun(I2PTunnelIRCClient.java:136)
         at net.i2p.i2ptunnel.I2PTunnelClientBase$BlockingRunner.run(I2PTunnelClientBase.java:830)
         at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1167)
         at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:641)
         at java.base/java.lang.Thread.run(Thread.java:844)
    10/19/18, 2:35:03 AM WARN [uter Restart] net.i2p.router.Router : Router teardown complete, restarting the router...
    10/19/18, 2:35:03 AM WARN [uter Restart] net.i2p.router.Router : Stopping the tunnel manager
    10/19/18, 2:40:47 AM WARN [uter Restart] net.i2p.router.Router : Stopping the comm system
    10/19/18, 2:40:47 AM ERROR [nal Reader 4] lient.impl.I2PSessionMuxedImpl: [OPEN Irc2P #35695]: Error occurred communicating with router: Router restart
         net.i2p.client.I2PSessionException: Disconnect Message received: Router restart
         at net.i2p.client.impl.DisconnectMessageHandler.handleMessage(DisconnectMessageHandler.java:33)
         at net.i2p.client.impl.I2PSessionImpl.messageReceived(I2PSessionImpl.java:956)
         at net.i2p.internal.QueuedI2CPMessageReader$QueuedI2CPMessageReaderRunner.run2(QueuedI2CPMessageReader.java:56)
         at net.i2p.data.i2cp.I2CPMessageReader$I2CPMessageReaderRunner.run(I2CPMessageReader.java:164)
         at java.base/java.lang.Thread.run(Thread.java:844)
         at net.i2p.util.I2PThread.run(I2PThread.java:103)
    10/19/18, 2:40:47 AM ERROR [nal Reader 2] lient.impl.I2PSessionMuxedImpl: [OPEN shared clients #40061]: Error occurred communicating with router: Router restart
         net.i2p.client.I2PSessionException: Disconnect Message received: Router restart
         at net.i2p.client.impl.DisconnectMessageHandler.handleMessage(DisconnectMessageHandler.java:33)
         at net.i2p.client.impl.I2PSessionImpl.messageReceived(I2PSessionImpl.java:956)
         at net.i2p.internal.QueuedI2CPMessageReader$QueuedI2CPMessageReaderRunner.run2(QueuedI2CPMessageReader.java:56)
         at net.i2p.data.i2cp.I2CPMessageReader$I2CPMessageReaderRunner.run(I2CPMessageReader.java:164)
         at java.base/java.lang.Thread.run(Thread.java:844)
         at net.i2p.util.I2PThread.run(I2PThread.java:103)
    10/19/18, 2:40:47 AM WARN [uter Restart] net.i2p.router.Router : Stopping the client manager
    10/19/18, 2:40:47 AM ERROR [uter Restart] net.i2p.router.Router : Stopping the router for a restart...
    10/19/18, 2:40:47 AM ERROR [uildExecutor] net.i2p.router.Router : Restarting after large clock shift forward by 5m
    10/19/18, 2:40:47 AM CRIT [uildExecutor] net.i2p.util.Clock : Large clock shift forward by 5m
  • Service (Wrapper) Logs
2018/10/18 20:28:44 | Launching a JVM...
2018/10/18 20:28:45 | WrapperManager: Initializing...
2018/10/18 20:28:45 | Starting I2P 0.9.37-0-1ubuntu1
2018/10/18 20:28:45 | INFO: Native CPUID library jcpuid-x86-linux loaded from file
2018/10/18 20:28:45 | INFO: Locally optimized library libjbigi-linux-coreihwl_64.so loaded from file
2018/10/19 02:35:10 | CRIT  [uildExecutor] net.i2p.util.Clock            : Large clock shift forward by 5m

Subtickets

Change History (3)

comment:1 Changed 14 months ago by Eche|on

Priority: criticalobsolete
Resolution: not a bug
Status: newclosed

Hi

as the client tunnels and local time on your system are completly seperated,t he on/offline of a service (not being NTP) is not the source of your clock shifting.
Please look out for other reason your clock shifts against snyched I2P time.

comment:2 Changed 14 months ago by anonymous maybe

Component: otherapi/i2cp
Priority: obsoleteminor
Resolution: not a bug
Status: closedreopened

another interesting thing i have discovered , the clock shifted skew and the upgrade happened with less than one hour after the upgrade happen. add to this the ONLY time my router clock time pushed like this in my router log, is when the upgrade happened.

[19:21:15] -Global- [Network Notice] zl0 - Hello Irc2P. The irc.00.i2p server will be offline for system maintenance starting around 2000 UTC, 18th October 2018. Downtime should not last longer than 24 hours. Thank you.

and my router clock skew

10/19/18, 2:40:47 AM Clock shifted 350714

40 minutes and 47 second…. Not a surprise?

Although it needs further investigations…

comment:3 Changed 14 months ago by Eche|on

Resolution: not a bug
Status: reopenedclosed

There is nothing combined with this, there is no way a encrypted irc client traffic (which does not get into the I2P router at all) will change the time on I2P.
You hunt ghosts here, sorry.

Note: See TracTickets for help on using tickets.