Opened 13 months ago

Closed 4 months ago

#2348 closed defect (worksforme)

i2psnark arm creates files before adding to index

Reported by: zzz Owned by: zzz
Priority: minor Milestone: 0.9.42
Component: apps/i2psnark Version: 0.9.37
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

on RPi adding huge torrent, takes forever to allocate file but 'downloading file' item is gone on torrent index and torrent isn't added to index yet, so it looks like it's gone. tf.isSparse should be false. Storage.java allocateFile(). So where in the code is it hung up and allocating everything before adding to index? Need thread dump.

Subtickets

Change History (2)

comment:1 Changed 4 months ago by zzz

Milestone: 0.9.380.9.42
Sensitive: unset

comment:2 Changed 4 months ago by zzz

Resolution: worksforme
Status: newclosed

Unable to reproduce on 0.9.41-7

Note: See TracTickets for help on using tickets.