Opened 3 months ago

Closed 2 months ago

Last modified 2 months ago

#2373 closed defect (fixed)

susimail attachments

Reported by: LeBleu Owned by: zzz
Priority: minor Milestone: 0.9.38
Component: apps/susimail Version: 0.9.37
Keywords: Cc: alex_the_designer, alex_wykoff
Parent Tickets:

Description

Hi !

Is this a bug?

I made several experiences sending and receiving messages between clear-web and I2P using the susimail client.

Sending clear-web to I2P: everything works fine and I notice that the attachments are automatically compressed in ZIP format (for more security !)

Sending I2P to the Web in plain text: simple messages are well transmitted. If there is an attachment, susimail places the message in the drafts folder and is never sent. Whatever the nature of the attached file (TXT, PGP, IMG, ZIP...), sending mail becomes impossible.

Has anyone encountered the same problems? Is it possible to send attachments between parallel worlds ?

Thank you for your help.

  • Google automatic translation, sorry -

System : UBUNTU 18.04.1 LTS - bionic
JAVA : openjdk 10.0.2
I2P : 0.9.37-0

Subtickets

Change History (10)

comment:1 Changed 3 months ago by zzz

  • Cc alex_the_designer alex_wykoff added
  • Component changed from unspecified to apps/susimail
  • Owner set to zzz

works for me, anything other info you can provide would be helpful.
Alex also has issues, awaiting details from him.

comment:2 Changed 3 months ago by alex_wykoff

I can confirm the issue as explained.
I had attempted to attach a file and sent it, but any messages with attachments failed. Messages without attachments still worked.

STR:

  1. Create an email with an attachment.
  2. Attempt to send the email.
  3. Watch for send confirmation message at the bottom of the window.

Expected Result:
Email sends without issue, message is moved to 'Sent' folder.

Actual Result:
Email fails to send. Red error message is displayed. Message stays in 'Draft' folder.

comment:3 Changed 3 months ago by alex_wykoff

Test system :
OS : Windows 10 Pro
Browser : Firefox 64.0
I2P : 0.9.37-0

comment:4 Changed 2 months ago by zzz

what's the error message? anything additional in the logs?

comment:5 Changed 2 months ago by alex_wykoff

The message reads as follows :
"Error sending mail: <name of file> (The system cannot find the file specified)
End data with <CR><LF>.<CR><LF>"

Nothing was being outputted to the browser console log, is there some other place to check?

comment:6 Changed 2 months ago by zzz

  • Milestone changed from undecided to 0.9.38
  • Status changed from new to accepted

comment:7 Changed 2 months ago by zzz

  • Resolution set to fixed
  • Status changed from accepted to closed

In 17a22db2e64db3ce2d9763ab09d1e2274238fcb5 0.9.37-17-rc

comment:8 Changed 2 months ago by zzz

One other thing, for testers:
If you have the message with an attachment still sitting in drafts after a failed send, you may have to either delete and recompose the message, or delete and re-add the attachment in it. Not sure if it will work if you just try to resend it.

comment:9 Changed 2 months ago by alex_wykoff

Just tried via a local build of i2p.i2p with latest changes. It appears to work for .jpg and .xml files, albeit both were on the smaller side.

Certainly an improvement over prior exhibited behavior.

If time allows, I'll attempt some other attachments in the next 24 hours.

comment:10 Changed 2 months ago by alex_wykoff

Updating to note that pdfs and mp4s work as well. I would consider this issue fixed.

Note: See TracTickets for help on using tickets.