Opened 3 months ago

Closed 3 months ago

#2378 closed defect (not a bug)

Updated configurations on /configtunnels do not reflect on /i2ptunnelmgr and vice versa.

Reported by: np-tokumei Owned by:
Priority: minor Milestone: undecided
Component: apps/desktopgui Version: 0.9.37
Keywords: Cc: zzz
Parent Tickets:

Description

I currently ran an eepsite and found that the configurations (e.g., numer of tunnels, number of hops, or number of backup tunnels) I set on either /configtunnels or /i2ptunnelmgr do not carry over to other.

Subtickets

Change History (1)

comment:1 Changed 3 months ago by zzz

  • Resolution set to not a bug
  • Status changed from new to closed

/configtunnels says right at the top:

Exploratory tunnel setting changes are stored in the router.config file. Client tunnel changes are temporary and are not saved. To make permanent client tunnel changes see the i2ptunnel page.

In the other direction, changes in i2ptunnelmgr are reflected on /configtunnels, except perhaps if the tunnel is configured for reduce-on-idle. I just retested and verified it works fine.

Note: See TracTickets for help on using tickets.