Opened 5 months ago

Closed 5 months ago

#2399 closed defect (fixed)

BW Test unchecked exception

Reported by: zzz Owned by: zzz
Priority: minor Milestone: 0.9.39
Component: apps/console Version: 0.9.38
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

when can't resolve hostname. Need to catch it and put error msg on results page.

Subtickets

Change History (2)

comment:1 Changed 5 months ago by zzz

Status: newaccepted
Exception in thread "MLabRunner" java.lang.IllegalArgumentException: java.net.UnknownHostException: ndt.iupui.donar.measurement-lab.org: Name or service not known
	at edu.internet2.ndt.Tcpbw100.setsHostName(Tcpbw100.java:4420)
	at edu.internet2.ndt.Tcpbw100.mainSupport(Tcpbw100.java:351)
	at com.vuze.plugins.mlab.MLabRunner$1.run(MLabRunner.java:174)
	at com.vuze.plugins.mlab.MLabRunner$2.run(MLabRunner.java:264)
Caused by: java.net.UnknownHostException: ndt.iupui.donar.measurement-lab.org: Name or service not known
	at java.net.Inet6AddressImpl.lookupAllHostAddr(Native Method)
	at java.net.InetAddress$2.lookupAllHostAddr(InetAddress.java:929)
	at java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1324)
	at java.net.InetAddress.getAllByName0(InetAddress.java:1277)
	at java.net.InetAddress.getAllByName(InetAddress.java:1193)
	at java.net.InetAddress.getAllByName(InetAddress.java:1127)
	at edu.internet2.ndt.Tcpbw100.setsHostName(Tcpbw100.java:4409)
	... 3 more

comment:2 Changed 5 months ago by zzz

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.