Opened 4 weeks ago

Closed 4 weeks ago

#2408 closed defect (fixed)

Installation / Update broken on with version 0.9.38 of I2P on Linux Mint 17.3 (32-bit)

Reported by: mint-i2p Owned by: zzz
Priority: critical Milestone: 0.9.38
Component: package/other Version: 0.9.38
Keywords: Cc:
Parent Tickets:

Description

I recently updated I2P to the latest release (0.9.38) via the I2P ppa. I am using Linux Mint 17.3 . When I run the I2P router I get an error message:

i2prouter: command not found

I tried doing a new install on another machine running running the same operating system and I received the same result.

I finally tried a third machine with Linux Mint 18, and it worked.

Subtickets

Change History (5)

comment:1 Changed 4 weeks ago by zzz

  • Component changed from unspecified to package/other

let us know if you figure out why

comment:2 Changed 4 weeks ago by echelon

  • Owner set to zzz
  • Priority changed from minor to critical
  • Status changed from new to assigned

hey

the ppa ubuntu packages for trusty and precise are empty for no yet known reason.
Seems like one of these are used in mint 17.3.
Please wait until we find the cause nad have redone the packages.

Sorry for the hassle

comment:3 Changed 4 weeks ago by zzz

The issue we're working on for precise and trusty is not applicable to xenial or higher.

Please let us know which repo of ours you're using for 17.3.

comment:4 Changed 4 weeks ago by echelon

Hi!

quick search:
18 Sarah Ubuntu Xenial
17.3 Rosa Ubuntu Trusty

https://linuxmint.com/download_all.php

comment:5 Changed 4 weeks ago by zzz

  • Milestone changed from undecided to 0.9.38
  • Resolution set to fixed
  • Status changed from assigned to closed

We have a fix, will be up on the PPA and deb repo shortly.
The issue appears to be specific to the launchpad builds; mhatta was unable to reproduce when building on debian wheezy (== precise).

New packages are:

i2p_0.9.38p-2~precise+1
i2p_0.9.38p-4~trusty+1

Note: See TracTickets for help on using tickets.