Opened 8 months ago

Closed 8 months ago

#2450 closed enhancement (not a bug)

Reduce connectDelay for HTTP Tunnels

Reported by: Zlatin Balevsky Owned by:
Priority: minor Milestone: undecided
Component: apps/i2ptunnel Version: 0.9.38
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

While investigating why 10 outproxies are slower than 1, it became apparent that with sites that load resources from multiple locations the latency is influenced a lot by the 1000ms connectDelay. When I changed that to 100ms sites started to load much faster.

I think 1000ms is too high for today's computers. GET requests usually get written before the Connection object is constructed. I haven't tested POST requests.

Subtickets

Change History (2)

comment:1 Changed 8 months ago by zzz

The connect delay for HTTP client shouldn't matter for GETs. We pull in all the headers in the proxy, write them out, and flush() at I2PTunnelRunner line 294. For POSTs, we'll flush() once we're out of data. That's the intent anyway. If flush() doesn't bypass the connectDelay, that's a bug.

comment:2 Changed 8 months ago by Zlatin Balevsky

Resolution: not a bug
Status: newclosed

Doesn't look like there's a bug, my observations must have been confirmation biased. Closing the ticket.

Note: See TracTickets for help on using tickets.