Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#2481 closed defect (fixed)

android i2ptunnel NullPointerException

Reported by: Meeh Owned by: Meeh
Priority: minor Milestone: 0.9.40
Component: apps/android Version: 0.9.39
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

java.lang.RuntimeException?:

at android.app.ActivityThread?.performResumeActivity (ActivityThread?.java:3558)
at android.app.ActivityThread?.handleResumeActivity (ActivityThread?.java:3598)
at android.app.ActivityThread?.handleLaunchActivity (ActivityThread?.java:2830)
at android.app.ActivityThread?.-wrap12 (ActivityThread?.java)
at android.app.ActivityThread?$H.handleMessage (ActivityThread?.java:1546)
at android.os.Handler.dispatchMessage (Handler.java:102)
at android.os.Looper.loop (Looper.java:154)
at android.app.ActivityThread?.main (ActivityThread?.java:6351)
at java.lang.reflect.Method.invoke (Native Method)
at com.android.internal.os.ZygoteInit?$MethodAndArgsCaller?.run (ZygoteInit?.java:896)
at com.android.internal.os.ZygoteInit?.main (ZygoteInit?.java:786)

Caused by: java.lang.RuntimeException?:

at android.app.ActivityThread?.deliverResults (ActivityThread?.java:4221)
at android.app.ActivityThread?.performResumeActivity (ActivityThread?.java:3532)

Caused by: java.lang.NullPointerException?:

at net.i2p.android.i2ptunnel.TunnelEntryAdapter?.addTunnel (TunnelEntryAdapter?.java:68)
at net.i2p.android.i2ptunnel.TunnelListFragment?.addTunnel (TunnelListFragment?.java:213)
at net.i2p.android.i2ptunnel.TunnelsContainer?.onActivityResult (TunnelsContainer?.java:221)
at android.support.v4.app.FragmentActivity?.onActivityResult (FragmentActivity?.java:160)
at android.app.Activity.dispatchActivityResult (Activity.java:7028)
at android.app.ActivityThread?.deliverResults (ActivityThread?.java:4217)

Subtickets

Change History (2)

comment:1 Changed 6 months ago by Meeh

Resolution: fixed
Status: newclosed

Pushed a fix.

comment:2 Changed 6 months ago by zzz

Milestone: undecided0.9.40

notes:
you think there's a race in there where in TunnelListFragment?, addTunnel() is called before onLoadFinished() ?

I think the Loader is asynch. If it finishes later, then the addTunnel will be lost

at least it won't NPE now. Please close ticket but say there may be a race in there still

Note: See TracTickets for help on using tickets.