Opened 3 weeks ago

Closed 3 weeks ago

#2482 closed defect (fixed)

android.content.res.Resources$NotFoundException NetDbStats

Reported by: meeh Owned by: meeh
Priority: minor Milestone: 0.9.40
Component: apps/android Version: 0.9.39
Keywords: Cc:
Parent Tickets:

Description

java.lang.RuntimeException?:

at android.support.v4.content.ModernAsyncTask?$3.done (ModernAsyncTask?.java:164)
at java.util.concurrent.FutureTask?.finishCompletion (FutureTask?.java:354)
at java.util.concurrent.FutureTask?.setException (FutureTask?.java:223)
at java.util.concurrent.FutureTask?.run (FutureTask?.java:242)
at java.util.concurrent.ThreadPoolExecutor?.runWorker (ThreadPoolExecutor?.java:1133)
at java.util.concurrent.ThreadPoolExecutor?$Worker.run (ThreadPoolExecutor?.java:607)
at java.lang.Thread.run (Thread.java:761)

Caused by: android.content.res.Resources$NotFoundException?:

at android.content.res.Resources.getText (Resources.java:377)
at android.content.res.Resources.getString (Resources.java:435)
at android.content.Context.getString (Context.java:481)
at net.i2p.android.router.netdb.NetDbStatsLoader?.classifyTransports (NetDbStatsLoader?.java:111)
at net.i2p.android.router.netdb.NetDbStatsLoader?.loadInBackground (NetDbStatsLoader?.java:57)
at net.i2p.android.router.netdb.NetDbStatsLoader?.loadInBackground (NetDbStatsLoader?.java:19)
at android.support.v4.content.AsyncTaskLoader?.onLoadInBackground (AsyncTaskLoader?.java:307)
at android.support.v4.content.AsyncTaskLoader?$LoadTask?.doInBackground (AsyncTaskLoader?.java:60)
at android.support.v4.content.AsyncTaskLoader?$LoadTask?.doInBackground (AsyncTaskLoader?.java:48)
at android.support.v4.content.ModernAsyncTask?$2.call (ModernAsyncTask?.java:141)
at java.util.concurrent.FutureTask?.run (FutureTask?.java:237)

Subtickets

Change History (2)

comment:1 Changed 3 weeks ago by meeh

  • Component changed from unspecified to apps/android
  • Owner set to meeh

comment:2 Changed 3 weeks ago by zzz

  • Milestone changed from undecided to 0.9.40
  • Resolution set to fixed
  • Status changed from new to closed

remap cases with no strings to a known case to prevent crash
also handle NTCP2 as NTCP
in c0204cdac2ab53b447e4dc299f0a1d9fff764320 to be 0.9.40

Note: See TracTickets for help on using tickets.