Opened 6 months ago

Closed 6 months ago

#2483 closed defect (fixed)

android TunnelUtil.createConfigFromWizard NullPointerException

Reported by: Meeh Owned by: Meeh
Priority: minor Milestone: 0.9.40
Component: apps/android Version: 0.9.39
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

java.lang.RuntimeException?:

at android.app.ActivityThread?.deliverResults (ActivityThread?.java:4433)
at android.app.ActivityThread?.handleSendResult (ActivityThread?.java:4476)
at android.app.ActivityThread?.-wrap19 (Unknown Source)
at android.app.ActivityThread?$H.handleMessage (ActivityThread?.java:1722)
at android.os.Handler.dispatchMessage (Handler.java:105)
at android.os.Looper.loop (Looper.java:164)
at android.app.ActivityThread?.main (ActivityThread?.java:6695)
at java.lang.reflect.Method.invoke (Native Method)
at com.android.internal.os.Zygote$MethodAndArgsCaller?.run (Zygote.java:240)
at com.android.internal.os.ZygoteInit?.main (ZygoteInit?.java:772)

Caused by: java.lang.NullPointerException?:

at net.i2p.android.i2ptunnel.util.TunnelUtil?.createConfigFromWizard (TunnelUtil?.java:583)
at net.i2p.android.i2ptunnel.util.TunnelUtil?.createConfigFromWizard (TunnelUtil?.java:571)
at net.i2p.android.i2ptunnel.TunnelsContainer?.onActivityResult (TunnelsContainer?.java:216)
at android.support.v4.app.FragmentActivity?.onActivityResult (FragmentActivity?.java:160)
at android.app.Activity.dispatchActivityResult (Activity.java:7255)
at android.app.ActivityThread?.deliverResults (ActivityThread?.java:4429)

Subtickets

Change History (2)

comment:1 Changed 6 months ago by Meeh

Component: unspecifiedapps/android
Owner: set to Meeh

comment:2 Changed 6 months ago by zzz

Milestone: undecided0.9.40
Resolution: fixed
Status: newclosed

Just a guess, hopefully fixed in b20e192f8640ccbd65c55261526122aee91ddd6c to be 0.9.40

Note: See TracTickets for help on using tickets.