Opened 10 years ago

Closed 9 years ago

#25 closed defect (fixed)

debian rules for building package of I2P are not up-to-date

Reported by: d3r3k4 Owned by:
Priority: minor Milestone: 0.8
Component: installer Version:
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

debian 'control' file has old version (0.7-0).

Source: i2p
Maintainer: jrandom
Section: net
Priority: optional
Homepage: http://dev.i2p2.de
Build-Depends: java-sdk, ant
Recommends: libgmp3c2
Version: 0.7-0
Tags: implemented-in::java, interface::daemon, network::client, network::server, role::program, security::cryptography

FYI - having this in main brach is not really OK as I think debian doesn't allow building of packages from source version systems, also there would be always problem how to detect version which was took from monotone.

I would recommend to have this only in release brach and to always modify version to version of release version.

Subtickets

Change History (2)

comment:1 Changed 10 years ago by anonymous

Milestone: 0.7.11

comment:2 Changed 9 years ago by zzz

Component: router/datainstaller
Priority: majorminor
Resolution: fixed
Status: newclosed

I changed our control file in January 2010 and updated the debian build scripts significantly, there is no Version line in there anymore. Released in 0.7.11.

Note: See TracTickets for help on using tickets.