Opened 6 months ago

Closed 6 months ago

#2517 closed defect (fixed)

0.9.40-7 does not build on buster, -2 did

Reported by: Eche|on Owned by: zzz
Priority: minor Milestone: 0.9.41
Component: package/debian Version: 0.9.40
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I did build 0.9.40-2 on my buster system fine, that version runs good. Today I did a apt-get upgrade and I tried mtn up, ant debian with -7 and I get this error, again it is jetty:

[mkdir] Created dir: /usr/src/i2p/i2p.i2p/apps/jetty/build

[exec] [mkdir] Created dir: /usr/src/i2p/i2p.i2p/apps/jetty/build/obj
[exec] [javac] Compiling 13 source files to /usr/src/i2p/i2p.i2p/apps/jetty/build/obj
[exec] [javac] warning: [options] bootstrap class path not set in conjunction with -source 7
[exec] [javac] /usr/src/i2p/i2p.i2p/apps/jetty/java/src/net/i2p/jetty/I2PRequestLog.java:27: warning: [deprecation] PathMap? in org.eclipse.jetty.http has been deprecated
[exec] [javac] import org.eclipse.jetty.http.PathMap?;
[exec] [javac]
[exec] [javac] /usr/src/i2p/i2p.i2p/apps/jetty/java/src/net/i2p/servlet/WebAppProviderConfiguration.java:3: error: package org.apache.tomcat does not exist
[exec] [javac] import org.apache.tomcat.SimpleInstanceManager?;
[exec] [javac]

[exec] [javac] /usr/src/i2p/i2p.i2p/apps/jetty/java/src/net/i2p/jetty/I2PRequestLog.java:83: warning: [deprecation] PathMap? in org.eclipse.jetty.http has been deprecated
[exec] [javac] private transient PathMap?<String> _ignorePathMap;
[exec] [javac]
[exec] [javac] /usr/src/i2p/i2p.i2p/apps/jetty/java/src/net/i2p/jetty/I2PRequestLog.java:486: warning: [deprecation] PathMap? in org.eclipse.jetty.http has been deprecated
[exec] [javac] _ignorePathMap = new PathMap?<String>();
[exec] [javac]

[exec] [javac] /usr/src/i2p/i2p.i2p/apps/jetty/java/src/net/i2p/servlet/WebAppProviderConfiguration.java:47: error: cannot find symbol
[exec] [javac] context.getServletContext().setAttribute("org.apache.tomcat.InstanceManager?", new SimpleInstanceManager?());
[exec] [javac]
[exec] [javac] symbol: class SimpleInstanceManager?
[exec] [javac] location: class WAPConfiguration
[exec] [javac] 2 errors
[exec] [javac] 4 warnings

apt-cache policy libjetty9-java
libjetty9-java:

Installed: 9.4.15-1
Candidate: 9.4.15-1
Version table:

9.4.18-1 100

libtomcat9-java:

Installed: 9.0.16-3
Candidate: 9.0.16-3
Version table:

* 9.0.16-3 430

I did copy over the alt-debian/bustter/* files to /debian, I did a fresh mtn co of the i2p.i2p branch, same error.

Subtickets

Change History (2)

comment:1 Changed 6 months ago by zzz

Milestone: undecided0.9.41
Status: newaccepted

OK, that is a new file, to fix #2477, just need to fix up the classpath for the debian flavor, stand by…

comment:2 Changed 6 months ago by zzz

Resolution: fixed
Status: acceptedclosed

Reproduced and fixed here on Cosmic.
In b7d75e42b9464557c4bbdef9398e6fe4c9ecb229 0.9.40-8

Note: See TracTickets for help on using tickets.