Opened 3 months ago

Closed 3 months ago

#2552 closed defect (fixed)

NullPointerException - net.i2p.android.i2ptunnel.util.TunnelUtil.createConfigFromWizard

Reported by: Meeh Owned by: Meeh
Priority: minor Milestone: 0.9.41
Component: apps/android Version: 0.9.40
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

java.lang.RuntimeException: 
  at android.app.ActivityThread.deliverResults (ActivityThread.java:4284)
  at android.app.ActivityThread.handleSendResult (ActivityThread.java:4327)
  at android.app.ActivityThread.-wrap22 (ActivityThread.java)
  at android.app.ActivityThread$H.handleMessage (ActivityThread.java:1624)
  at android.os.Handler.dispatchMessage (Handler.java:105)
  at android.os.Looper.loop (Looper.java:156)
  at android.app.ActivityThread.main (ActivityThread.java:6523)
  at java.lang.reflect.Method.invoke (Native Method)
  at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run (ZygoteInit.java:942)
  at com.android.internal.os.ZygoteInit.main (ZygoteInit.java:832)
Caused by: java.lang.NullPointerException: 
  at net.i2p.android.i2ptunnel.util.TunnelUtil.createConfigFromWizard (TunnelUtil.java:592)
  at net.i2p.android.i2ptunnel.util.TunnelUtil.createConfigFromWizard (TunnelUtil.java:576)
  at net.i2p.android.i2ptunnel.TunnelsContainer.onActivityResult (TunnelsContainer.java:219)
  at android.support.v4.app.FragmentActivity.onActivityResult (FragmentActivity.java:160)
  at android.app.Activity.dispatchActivityResult (Activity.java:7193)
  at android.app.ActivityThread.deliverResults (ActivityThread.java:4280)

Subtickets

Change History (3)

comment:1 Changed 3 months ago by zzz

Milestone: undecided0.9.41

1 report, 1 user, should be fixable

comment:2 Changed 3 months ago by Meeh

This happened only once, on a Huawei Honor 8 (HWFRD), Android 7.0.

comment:3 Changed 3 months ago by Meeh

Resolution: fixed
Status: newclosed

Hopefully fixed. I'll keep an watch if my fix caused any issues in the future.

Note: See TracTickets for help on using tickets.