Opened 3 months ago

Closed 3 months ago

#2557 closed defect (fixed)

Network Hidden Bug

Reported by: sadie Owned by: zzz
Priority: minor Milestone: 0.9.41
Component: router/transport Version: 0.9.40
Keywords: Network Hidden Cc: zzz
Parent Tickets: Sensitive: no

Description

Version 0.9.40-10
Started I2P in Tunis - Network was hidden.
Returned to Canada - Network was still set to Hidden mode.
Restarted - remained in Hidden mode.
Had to de select "hidden" from preferences, restart.

Subtickets

Change History (3)

comment:1 Changed 3 months ago by zzz

Component: router/netdbrouter/transport
Status: newaccepted

will try to reproduce without travelling to Tunisia

comment:2 Changed 3 months ago by sadie

we also discussed testing hidden mode performance which I can do.

comment:3 Changed 3 months ago by zzz

Milestone: undecided0.9.41
Resolution: fixed
Status: acceptedclosed

Not sure exactly what happened here but I fixed some issues with detecting IP and country when in hidden mode, which would prevent coming out of it, in 4832856017b0c6169942f937e90033107b0296e7 0.9.40-14-rc. I did my best to review and test with some forced settings, but I didn't get on a plane.

Note that if a user has ever set hidden mode manually on /confignet, whether he leaves that setting or later changes the setting back to some other setting, hidden mode is from then on forced on (or off) and there's no way to get back to automatic, other than removing the "router.isHidden" setting on /configadvanced. Nobody's complained about that before, but the fix would be to split out the hidden mode setting into its own section with off/on/auto choices.

Note: See TracTickets for help on using tickets.