Opened 2 weeks ago

Closed 13 days ago

#2611 closed enhancement (not a bug)

Use HEAD before attempting GET for susidns subscriptions

Reported by: Reportage Owned by:
Priority: minor Milestone: undecided
Component: apps/susidns Version: 0.9.42
Keywords: susidns, subscriptions Cc:
Parent Tickets: Sensitive: no

Description

SusiDNS should check the timestamp of subscription urls via a HEAD request and only perform a GET if the timestamp is newer than the existing local subscription, to save bandwidth and server load.

Subtickets

Change History (1)

comment:1 Changed 13 days ago by zzz

Resolution: not a bug
Status: newclosed

Not necessary, we already do something even better.
SusiDNS+eepget support standard HTTP conditional headers Etag and If-Modified-Since. Susidns stores and returns the values from the last fetch. Compliant web servers will return 304 if not modified. No separate HEAD is required.

Note: See TracTickets for help on using tickets.