Opened 4 months ago

Closed 4 months ago

#2624 closed defect (not a bug)

Warning: apt-key should not be used in scripts

Reported by: anonymous maybe Owned by: zzz
Priority: minor Milestone: n/a
Component: package/debian Version: 0.9.42
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

Updating i2p-keyring resulted in:

The following packages will be upgraded:
  i2p-keyring
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 14.5 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 https://deb.i2p2.de buster/main amd64 i2p-keyring all 2019.09.21 [14.5 kB]
Fetched 14.5 kB in 1s (16.8 kB/s)                    
(Reading database ... 38569 files and directories currently installed.)
Preparing to unpack .../i2p-keyring_2019.09.21_all.deb ...
Unpacking i2p-keyring (2019.09.21) over (2018.09.16) ...
Setting up i2p-keyring (2019.09.21) ...
Adding/refreshing keys:
  67ECE5605BCF1346 1381446626  [ expires 1633876597 ]
... Warning: apt-key should not be used in scripts (called from postinst maintainerscript of the package i2p-keyring)
OK
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded

Subtickets

Change History (1)

comment:1 Changed 4 months ago by zzz

Milestone: undecidedn/a
Resolution: not a bug
Status: newclosed

You can ignore this warning. The sole purpose of this package is to run apt-key.

Note: See TracTickets for help on using tickets.