Opened 5 months ago

Last modified 2 months ago

#2627 new defect

Upgrade 0.9.41 -> 0.9.42 on Debian Stretch 32bit does not work

Reported by: fort1 Owned by: zzz
Priority: minor Milestone: undecided
Component: package/debian Version: 0.9.44
Keywords: i2p-router, debian, 32bit Cc: Masayuki Hatta
Parent Tickets: Sensitive: no

Description (last modified by Eche|on)

The following packages have unmet dependencies:
i2p-router : Depends: libtomcat9-java but it is not going to be installed

Try the backports:
https://packages.debian.org/stretch-backports/all/libtomcat9-java/download

Subtickets

Change History (6)

comment:1 Changed 5 months ago by Eche|on

Component: installerpackage/ubuntu
Description: modified (diff)
Owner: set to zzz

comment:2 Changed 5 months ago by zzz

Cc: Masayuki Hatta added
Component: package/ubuntupackage/debian
Priority: maintenanceminor

Where did you get the package? From official Debian or our PPA?

I don't see i2p in Debian stretch anymore: https://packages.debian.org/sid/i2p - or maybe it was removed because it is broken?
But the version in our PPA doesn't depend on libtomcat-9

Should ask mhatta to look into it

comment:3 Changed 5 months ago by fort1

I use:
http://http.debian.net/debian stretch-backports main
http://deb.i2p2.no/ stable main

comment:4 Changed 2 months ago by fort1

The following packages have unmet dependencies:

i2p-router : Depends: libjetty9-java (≥ 9.4) but 9.2.21-1+deb9u1 is to be installed

E: Unable to correct problems, you have held broken packages.

comment:5 Changed 2 months ago by fort1

Version: 0.9.420.9.44

comment:6 Changed 2 months ago by zzz

The i2p package in our Debian repo for Stretch does not depend on Jetty (9.2 or 9.4) or Tomcat. It sounds like you have our Buster version.

Note: See TracTickets for help on using tickets.