Opened 3 weeks ago

Closed 6 days ago

#2662 closed defect (fixed)

I2PSnark opens tunnels at startup when no torrents are running

Reported by: Reportage Owned by: zzz
Priority: minor Milestone: 0.9.44
Component: apps/i2psnark Version: 0.9.43
Keywords: I2PSnark, startup, tunnels Cc:
Parent Tickets: Sensitive: no

Description

I2PSnark should check if torrents are running at startup before opening tunnels; currently it opens the minimum configured number of tunnels regardless.

Subtickets

Change History (4)

comment:1 Changed 2 weeks ago by zzz

Status: newinfoneeded_new

Cannot reproduce here with autostart off.
With autostart on, it should start the tunnels.
With autostart on but no torrents running, I don't know what it did before or should do, but I don't think the recent change #2623 would have made it any different.
Please clarify your configuration.

comment:2 Changed 2 weeks ago by Reportage

Status: infoneeded_newnew

Problem occurs with autostart on when all torrents in the session are stopped. Was probably introduced when #2120 was fixed.

If autostart is on but all torrents are stopped, tunnels should not be opened at startup.

comment:3 Changed 7 days ago by zzz

Milestone: undecided0.9.44

Thanks, not a big issue, but will try to fix it. Will have to move some code around.

comment:4 Changed 6 days ago by zzz

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.