Opened 3 months ago

Closed 3 months ago

#2712 closed defect (not a bug)

Outproxy not found

Reported by: curewindow Owned by:
Priority: minor Milestone: undecided
Component: apps/i2ptunnel Version: 0.9.45
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I can visit many i2p eepsites as usual. I have green light for tunnels and peers are enough. However, I have received the warning for several weeks when I visit any non-i2p website.

The HTTP Outproxy was not found. It is offline, there is network congestion, or your router is not yet well-integrated with peers. You may want to retry as this will randomly reselect an outproxy from the pool you have defined here (if you have more than one configured). If you continue to have trouble you may want to edit your outproxy list here.

I have set the browser proxy as 127.0.0.1 4444 (http) and 4445(ssl). My HTTP Outproxy: false.i2p, HTTPS Outproxy: outproxy-tor.meeh.i2p.
I know that false.i2p is slow. But my i2p used to be fine. The problem took place first when I updated to 0.9.45. I can always visit clearnet such as google via i2p before that. The problem goes on after I deleted i2p totally and reinstalled 0.9.41 and reseeds. I tried several browsers. I configured "Prefer IPv4 over IPv6". I removed the "::1," in the "clientApp.0.args" line, and added "wrapper.java.additional.5=-Djava.net.preferIPv4Stack=true" and "wrapper.java.additional.6=-Djava.net.preferIPv6Addresses=false" as ticket:1400.

ROUTER LOGS: Nothing.

SERVICE (WRAPPER) LOGS
INFO: Native CPUID library jcpuid-x86-windows loaded from file
INFO: Locally optimized library jbigi-windows-athlon64.dll loaded from file
WARN: Configured for 50.00MiBps share bandwidth but only 123.75MiB available memory. Recommend running the restartable version of I2P, and increasing wrapper.java.maxmemory in …\i2p\wrapper.config to at least 140 (MB) if the actual share bandwidth exceeds 512.00KiBps.
WARNING: Error starting ConsoleSocket?@……{HTTP/1.1}{::1:7657}: java.net.SocketException?: Address family not supported by protocol family: bind
java.net.SocketException?: Address family not supported by protocol family: bind

at sun.nio.ch.Net.bind0(Native Method)
at sun.nio.ch.Net.bind(Unknown Source)
at sun.nio.ch.Net.bind(Unknown Source)
at sun.nio.ch.ServerSocketChannelImpl?.bind(Unknown Source)
at sun.nio.ch.ServerSocketAdaptor?.bind(Unknown Source)
at org.eclipse.jetty.server.ServerConnector?.open(ServerConnector?.java:321)
at org.eclipse.jetty.server.AbstractNetworkConnector?.doStart(AbstractNetworkConnector?.java:80)
at org.eclipse.jetty.server.ServerConnector?.doStart(ServerConnector?.java:236)
at org.eclipse.jetty.util.component.AbstractLifeCycle?.start(AbstractLifeCycle?.java:68)
at net.i2p.router.web.RouterConsoleRunner?.startConsole(RouterConsoleRunner?.java:769)
at net.i2p.router.web.RouterConsoleRunner?.startup(RouterConsoleRunner?.java:235)
at net.i2p.router.startup.RouterAppManager?.addAndStart(RouterAppManager?.java:54)
at net.i2p.router.startup.LoadClientAppsJob?$RunApp?.run(LoadClientAppsJob?.java:301)
at java.lang.Thread.run(Unknown Source)
at net.i2p.util.I2PThread.run(I2PThread.java:103)

WARNING: Error starting one or more listeners of the Router Console server.
If your console is still accessible at http://127.0.0.1:7657/,
this may be a problem only with binding to the IPV6 address ::1.
If so, you may ignore this error, or remove the
"::1," in the "clientApp.0.args" line of the clients.config file.

Subtickets

Change History (1)

comment:1 Changed 3 months ago by Eche|on

Resolution: not a bug
Status: newclosed

Hi

thats noit a bug, as the outproxy sometimes maybe down or unreachable due to several issues. Also some notes in FAW about services not reachable already: http://geti2p.net/en/faq

The issue in the log just shows you are not using IPv6 on a local network.

e

Note: See TracTickets for help on using tickets.