Opened 4 months ago

Last modified 4 months ago

#2722 new defect

Addressbook not accepting addresses. Java errors.

Reported by: Steve Smith Owned by: Meeh
Priority: major Milestone: undecided
Component: apps/browser Version: 0.9.43
Keywords: addressbook java Cc:
Parent Tickets: Sensitive: no

Description

Trying to visit some sites listed on identiguy.i2p but with no luck. Entered the address to the hosts.txt file in the subscription window of the browser and clicked save then reload. Could not go to the url even though it is listed in the hosts.txt file. Tried to place the downloaded file renamed to privatehosts.txt and tried userhosts.txt into the directory above the addressbook directory. Actually tried several locations but the aforementioned should be the correct one. Upon navigating to http://localhost:7647/susidns/addressbook?book=private&filter=none, I get the below error. The error shows on all of the host files. On my Linux install, this seriously diminishes the i2p experience. Also tried to restart the browser several times but to no avail. The addressbook just does not work.

Error 500: /susidns/addressbook javax.servlet.ServletException?: java.lang.NoClassDefFoundError?: org/apache/taglibs/standard/tag/rt/core/ForEachTag

javax.servlet.ServletException?: java.lang.NoClassDefFoundError?: org/apache/taglibs/standard/tag/rt/core/ForEachTag

at jasper.runtime/org.apache.jasper.runtime.PageContextImpl?.doHandlePageException(Unknown Source)
at jasper.runtime/org.apache.jasper.runtime.PageContextImpl?.handlePageException(Unknown Source)
at i2p.susi.dns.jsp.addressbook_jsp._jspService(addressbook_jsp.java:683)
at jasper.runtime/org.apache.jasper.runtime.HttpJspBase?.service(Unknown Source)
at javax.servlet/javax.servlet.http.HttpServlet?.service(Unknown Source)
at jetty.servlet/org.eclipse.jetty.servlet.ServletHolder?.handle(Unknown Source)
at jetty.servlet/org.eclipse.jetty.servlet.ServletHandler?$CachedChain?.doFilter(Unknown Source)
at jetty.i2p/net.i2p.servlet.filters.XSSFilter.doFilter(Unknown Source)
at jetty.servlet/org.eclipse.jetty.servlet.ServletHandler?$CachedChain?.doFilter(Unknown Source)
at jetty.servlet/org.eclipse.jetty.servlet.ServletHandler?.doHandle(Unknown Source)
at org.mortbay.jetty/org.eclipse.jetty.server.handler.ScopedHandler?.handle(Unknown Source)
at jetty.security/org.eclipse.jetty.security.SecurityHandler?.handle(Unknown Source)
at org.mortbay.jetty/org.eclipse.jetty.server.session.SessionHandler?.doHandle(Unknown Source)
at org.mortbay.jetty/org.eclipse.jetty.server.handler.ContextHandler?.doHandle(Unknown Source)
at jetty.servlet/org.eclipse.jetty.servlet.ServletHandler?.doScope(Unknown Source)
at org.mortbay.jetty/org.eclipse.jetty.server.session.SessionHandler?.doScope(Unknown Source)
at org.mortbay.jetty/org.eclipse.jetty.server.handler.ContextHandler?.doScope(Unknown Source)
at org.mortbay.jetty/org.eclipse.jetty.server.handler.ScopedHandler?.handle(Unknown Source)
at org.mortbay.jetty/org.eclipse.jetty.server.handler.ContextHandlerCollection?.handle(Unknown Source)
at jetty.servlets/org.eclipse.jetty.servlets.gzip.GzipHandler?.handle(Unknown Source)
at routerconsole/net.i2p.router.web.HostCheckHandler?.handle(Unknown Source)
at org.mortbay.jetty/org.eclipse.jetty.server.handler.HandlerCollection?.handle(Unknown Source)
at org.mortbay.jetty/org.eclipse.jetty.server.handler.HandlerWrapper?.handle(Unknown Source)
at org.mortbay.jetty/org.eclipse.jetty.server.Server.handle(Unknown Source)
at org.mortbay.jetty/org.eclipse.jetty.server.HttpChannel?.handle(Unknown Source)
at org.mortbay.jetty/org.eclipse.jetty.server.HttpConnection?.onFillable(Unknown Source)
at jetty.io/org.eclipse.jetty.io.AbstractConnection?$2.run(Unknown Source)
at jetty.util/org.eclipse.jetty.util.thread.QueuedThreadPool?.runJob(Unknown Source)
at jetty.util/org.eclipse.jetty.util.thread.QueuedThreadPool?$3.run(Unknown Source)
at java.base/java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NoClassDefFoundError?: org/apache/taglibs/standard/tag/rt/core/ForEachTag
at i2p.susi.dns.jsp.addressbook_jsp._jspx_meth_c_005fforEach_005f0(addressbook_jsp.java:697)
at i2p.susi.dns.jsp.addressbook_jsp._jspService(addressbook_jsp.java:204)
… 27 more


Subtickets

#2723: The information you requested.closed

Change History (5)

comment:1 Changed 4 months ago by Eche|on

Hi.

the error shows you are missing some class from taglib on your system.
which system/java do you use?

comment:2 Changed 4 months ago by zzz

You set the component to apps/browser - is this I2P browser, or a regular I2P installation?

Is it a debian/ubuntu package build?

Please provide full version information from the top of /logs

comment:3 Changed 4 months ago by Steve Smith

Add a subticket #2723 (The information you requested.).

Sorry. I know what you mean now about the logs.

I2P version: 0.9.43-0
Java version: AdoptOpenJDK 11.0.4 (OpenJDK Runtime Environment 11.0.4+11)
Wrapper version: none
Server version: 9.2.z-SNAPSHOT
Servlet version: Jasper JSP 2.3 Engine
JSTL version: n/a
Platform: Linux amd64 5.4.31-1-MANJARO
Processor: uninitialized (none)
JBigI status: Native BigInteger? library jbigi not loaded - using pure Java - poor performance may result - see http://i2p-projekt.i2p/jbigi for help
GMP version: unknown
JBigI version: 0
JCpuId version: 0
Encoding: UTF-8
Charset: UTF-8
Built By: Undefined

Last edited 4 months ago by Steve Smith (previous) (diff)

comment:4 Changed 4 months ago by Eche|on

Thats a old version, please update to 0.9.45

And manjaro linux is not official supported, maybe they do have issues with their packages.
Also no knwon libjbigi, thats strange. Strange CPU in your system?

Or do you use the i2p browser, which is dropped from support and unmaintained?
If yo, please use plain i2p, which should work better.

comment:5 Changed 4 months ago by zzz

Version: 0.9.450.9.43

probably a i2p browser problem, but the i2p browser project is dead: http://zzz.i2p/topics/2849

i2p browser knows nothing about i2pd. The issue is about the addressbook UI (susidns) in the browser, not the i2pd addressbook.

probably a missing jar. possibly related to adoptopenjdk, but probably not. Assigned to meeh from the browser team, you could wait, but while you're waiting, uninstall i2p browser, it's dead.

Note: See TracTickets for help on using tickets.