Opened 4 months ago

Closed 4 months ago

#2724 closed defect (not a bug)

Can't connect to i2p via localhost:7657

Reported by: Steve Smith Owned by:
Priority: minor Milestone: undecided
Component: unspecified Version: 0.9.45
Keywords: new-user Cc:
Parent Tickets: Sensitive: no

Description

From ticket 2722-2723 which is closed. Ditched the i2pbrowser which uses version 0.9.43 and installed i2p from source successfully as well as kept i2pd which is 0.9.45. Neither one of those will allow my browser to connect. That is why I used i2pbrowser in the first place. I get "localhost refused to connect". I know this isn't a bug, just something off with my system. I figured that you might know what and I thank you for any help. My firewall is off. If this is a configuration problem, then what do I do. There is no file to assist me. Been using Linux for 20 years and I am not used to failing.

wrapper.log


2020/04/17 13:44:45 | —> Wrapper Started as Daemon
2020/04/17 13:44:45 | Java Service Wrapper Community Edition 64-bit 3.5.39
2020/04/17 13:44:45 | Copyright © 1999-2019 Tanuki Software, Ltd. All Rights Reserved.
2020/04/17 13:44:45 | http://wrapper.tanukisoftware.com
2020/04/17 13:44:45 |
2020/04/17 13:44:46 | Launching a JVM…
2020/04/17 13:44:46 | WrapperManager?: Initializing…
2020/04/17 13:44:46 | Starting I2P 0.9.45-0
2020/04/17 13:44:46 | INFO: Native CPUID library libjcpuid-x86-linux.so loaded from resource
2020/04/17 13:44:46 | INFO: Loaded library: jar:file:/SHARED_APPS/Programs/Linux/with-prefix/i2p-0.9.45/lib/jbigi.jar!/libjbigi-linux-coreibwl_64.so
2020/04/17 13:44:46 | INFO: Native BigInteger? library libjbigi-linux-coreibwl_64.so loaded from resource
2020/04/17 13:44:46 | Warning - No client apps or router console configured - we are just a router
2020/04/17 13:44:47 | Reseed start
2020/04/17 13:44:47 | Reseeding from https://reseed.memcpy.io/i2pseeds.su3?netid=2
2020/04/17 13:44:48 | INFO: 77 files extracted to /tmp/i2p-5kwoxQQh.tmp/reseeds-500015069
2020/04/17 13:44:48 | Reseed got 77 router infos from https://reseed.memcpy.io/i2pseeds.su3?netid=2 with 0 errors

router.config


# NOTE: This I2P config file must use UTF-8 encoding
# Last saved: Apr 17, 2020, 2:25 PM
i2np.lastCountry=XX
i2np.lastIP=XXX.XXX.XXX.XXX
i2np.lastIPChange=1587145599607
i2np.ntcp2.iv=aIJbq1RJk24Z3-0t7Rddiw==
i2np.ntcp2.sp=GLWV2Xa1Ze8LSm2xG7vsZJ3ipdlpXQHoDEcGyhGSReE=
i2np.udp.internalPort=21617
i2np.udp.port=21617
jbigi.lastProcessor=Kaby Lake Core i3/i5/i7/64
jbigi.loadedResource=libjbigi-linux-coreibwl_64.so
router.firstInstalled=1587145486563
router.firstVersion=0.9.45
router.inboundPool.randomKey=YEYwvWLm8aKEFFX4HWvY0pAqSrdGVNcnmBxUEa8bFwA=
router.outboundPool.randomKey=Jcyy9-nqWRrfqggJAsOglEBCYuWd4S2sVJpDtAWQLHg=
router.previousVersion=0.9.45
router.updateLastInstalled=1587145486563

Subtickets

Change History (1)

comment:1 Changed 4 months ago by Eche|on

Resolution: not a bug
Status: newclosed

Your config is not readable or not available.
| Warning - No client apps or router console configured - we are just a router

You did set it to be just a i2p router, nothing more than a i2p router is started, no router console, no clients, nothing else.

Check the user as which I2P runs and the i2p settings you did set to run I2P with.

Note: See TracTickets for help on using tickets.