Opened 6 months ago

Closed 6 months ago

#2743 closed defect (fixed)

i2psnark: delete button js handlers lost after XHR refresh

Reported by: zzz Owned by: zzz
Priority: minor Milestone: 0.9.47
Component: apps/i2psnark Version: 0.9.46
Keywords: Cc: Reportage
Parent Tickets: Sensitive: no

Description

broken by me. works fine if refresh disabled.
as reported by drz.

Subtickets

Change History (2)

comment:1 Changed 6 months ago by zzz

Status: newaccepted

Root cause: I tested the change with refresh disabled because I was using inspect element. I didn't retest with refresh enabled.

comment:2 Changed 6 months ago by zzz

Resolution: fixed
Status: acceptedclosed

In abbc8847148c0d67365ef9a3ad595f801287226d to be 0.9.46-3, using js event delegation as recommended by drzed.

Note: See TracTickets for help on using tickets.