Opened 5 weeks ago

Closed 3 weeks ago

#2745 closed defect (fixed)

MuWire incompatible with OpenJDK 14

Reported by: tom.candle Owned by: zlatinb
Priority: minor Milestone: undecided
Component: apps/plugins Version: 0.9.46
Keywords: muwire Cc:
Parent Tickets: Sensitive: no

Description

I am using OpenJDK 14.

I2P has been updated to support OpenJDK, as stated here:
http://trac.i2p2.i2p/ticket/741

But trying to install the current version of MuWire? from
http://muwire.i2p/MuWire.su
gives me the following stack-trace.
[…]
jvm 1 | ERROR: Error extracting the zip entry (lib/groovy-json-2.4.15.jar.pack)
jvm 1 | java.io.IOException: Unpack200 not supported
jvm 1 | at net.i2p.util.FileUtil?.unpack(FileUtil?.java:354)
jvm 1 | at net.i2p.util.FileUtil?.extractZip(FileUtil?.java:160)
jvm 1 | at net.i2p.router.update.PluginUpdateRunner?.getPluginConfig(PluginUpdateRunner?.java:378)
jvm 1 | at net.i2p.router.update.PluginUpdateRunner?.processSU3(PluginUpdateRunner?.java:348)
jvm 1 | at net.i2p.router.update.PluginUpdateRunner?.transferComplete(PluginUpdateRunner?.java:193)
jvm 1 | at net.i2p.router.update.PluginUpdateRunner?.update(PluginUpdateRunner?.java:119)
jvm 1 | at net.i2p.router.update.UpdateRunner?.run(UpdateRunner?.java:122)
[…]

I downloaded the MuWire?.su3 and checked it with 7Zip. The file still contains some files packed with Unpack200, which is no longer part of OpenJDK. This should be fixed.

Subtickets

Change History (3)

comment:1 Changed 5 weeks ago by zzz

Owner: changed from zzz to zlatinb
Status: newassigned

comment:2 Changed 4 weeks ago by Zlatin Balevsky

Version 0.7.1-b1 is now available at http://muwire.i2p/MuWire.su3 without pack200 compression. Size is ~8.5MB

comment:3 Changed 3 weeks ago by Zlatin Balevsky

Resolution: fixed
Status: assignedclosed

Haven't heard from OP in a week, assuming everything works. If there are further issues pls reopen this ticket.

Note: See TracTickets for help on using tickets.