Opened 3 weeks ago

Closed 2 weeks ago

#2762 closed defect (not a bug)

Susimail: Delete confirmation doesn't work (ie. canceling deletion does nothing, email deletes)

Reported by: JK Owned by: zzz
Priority: minor Milestone: undecided
Component: apps/susimail Version: 0.9.46
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

As the title says.

This may have been report previously but access to the ticket seems to be broken (see below)?:
[484d4e2]: SusiMail?: Don't require confirmation to delete from Trash, Clear …

SusiMail?: Don't require confirmation to delete from Trash, Clear reallydelete flag when clicking cancel or change folder
By zzz <zzz@…> — May 30, 2018 11:51:14 PM

Subtickets

Change History (5)

comment:1 Changed 3 weeks ago by zzz

Component: unspecifiedapps/susimail
Owner: set to zzz

comment:2 Changed 3 weeks ago by zzz

Status: newinfoneeded_new

Tested here both cancel on the individual email view page, and on the folder page after clicking the really delete box, cancellation works, the email was not deleted.
Please provide full version info from the logs page, browser version, and any other pertinent info.

Also confirm javascript is enabled (if not, maybe it's a bug only when js is disabled?)

comment:3 Changed 2 weeks ago by JK

Status: infoneeded_newnew

Aha! My bad. I did some extra testing.

No I was not deleting them but "Move to Folder: Sent"ing them.

I didn't understand that button was for moving the actual email, not yourself. I would press "Move to Sent" then immediately on that Sent page the similar button to jump to the Inbox. This might be an interface problem, I think I may have been doing this for a while and not noticing. I might be able to help here, if others think that the interface can be improved, I do have some web development experience. I wonder if we can achieve something better and that has a more "material design feel". Maybe a hamburger menu of sorts with the name of the folder next to it.

So if you are looking at in email in your Inbox, at the very top right of your screen is a hamburger menu, and to the immediate Left of that is the folder name "Inbox". When the user taps on "Inbox" they go back to the Inbox. If they tap the hamburger menu a simple dropdown menu with the folders 'Inbox', 'Sent' etc would appear (it might appear either by using the Radio Box Hack or the details element or another method). All the user would need to do to access another folder is tap on it in the list to jump to the folder, ie. we skip any "form submission" process, even without javascript.

Should I open a new ticket for this with ideas on how we might be able to improve the interface slightly? Or is one of the forums a better place?

comment:4 Changed 2 weeks ago by JK

The problem is we have to different functions that look the same and appear in the same place but do two different things depending on the 'state'. The two 'states' being reading an email or viewing a list of emails.

I think this does need to be addressed for UI readability and ease of use.

comment:5 Changed 2 weeks ago by zzz

Resolution: not a bug
Status: newclosed

Trac isn't the best place for ideas and discussions, you could try a forum or IRC. Sadie and IDK are the UI people if you can find them. There's very little resources available for susimail but we may be able to tweak some things. Agreed the move to / change to interfaces aren't ideal. We're getting a little better at js, perhaps that could help.

Note: See TracTickets for help on using tickets.