Opened 4 months ago

Last modified 7 weeks ago

#2764 new defect

Windows installer stops at BOB.jar

Reported by: birdhops Owned by:
Priority: minor Milestone: undecided
Component: installer Version: 0.9.46
Keywords: install, windows Cc:
Parent Tickets: Sensitive: no

Description

I'm on Windows 10, Java build 1.8.0_261-b12. I tried to install i2p.
The installer runs indefinitely, stuck at the point when it copies BOB.jar to <installfolder>/lib.

https://imgur.com/a/AwEoUhi

Attempted this a couple of times, with the same result.

Subtickets

#2778: Exception in thread "IzPack - Unpacker thread"closedzzz

Change History (6)

comment:1 Changed 4 months ago by Zlatin Balevsky

Hi,
do you have an anti-virus program of any kind that could be detecting the java executable as a threat and putting it under quarantine?

comment:2 Changed 4 months ago by zzz

I think BOB.jar is the last one, and it may be hanging on the fixperms.bat script. Please provide info on your hardware platform, and where you're installing it (default location? network drive? thumb drive?) How long are you waiting? The script could take a few seconds, or maybe up to a minute worst case?

comment:3 Changed 3 months ago by zzz

possibly related: https://www.reddit.com/r/i2p/comments/iau8a9/installation_finished_on_i2plibbobjar/

but fixperms.bat is only a windows thing.

may be just an izpack UI problem, where the next button remains greyed out? is it clickable anyway?

comment:4 Changed 3 months ago by aargh

Keywords: install windows added
Status: newinfoneeded_new

comment:5 Changed 7 weeks ago by bmalex

Add a subticket #2778 (Exception in thread "IzPack? - Unpacker thread").

comment:6 Changed 7 weeks ago by zzz

Status: infoneeded_newnew

See child #2778 for same symptoms on Java 14. Workaround is to use Java 13 or lower. OP here reports Java 8. If that's wrong and it was actually picking up Java 14 or higher, the fix is in #2778.

Please double-check installed Java version and report.

Note: See TracTickets for help on using tickets.