Opened 15 months ago

Closed 6 months ago

#2765 closed defect (fixed)

Susimail: Email responses appear both truncated and repeat the first 1000 or so characters

Reported by: JK Owned by: zzz
Priority: major Milestone: 0.9.50
Component: apps/susimail Version: 0.9.46
Keywords: Cc:
Parent Tickets: Sensitive: no

Description (last modified by JK)

This happened to me three times in the recent past. To reproduce, I open an email response(!) from someone, the first 1000 characters or so of the email will repeat an extra 2 or three times, and thus the not show the full email! The only way I found to read to email properly was to find it, stored in plain text(!) in the i2p folder, susimail/<RaNdOm_F0LD3r>/cur/s<X>/<emA1L>.tar and read it from there.

It was actually a bit strange in that all the other tar'd emails that I opened in the folder, opened immediately but the affected email actually took SO LONG to open that I chose to load it in a different program, where it loaded immediately.

I went back to look at how the other two email were affected and they are no longer affected by this. This seems to be related to other issues that go away with time or with refresh. There does seem to be some IO issues when reading some emails, so maybe all these issues are related to IO exceptions, in some way.

Subtickets

Change History (4)

comment:1 Changed 15 months ago by JK

Description: modified (diff)
Summary: Susimail: Email responses appear both trucated and repeat the first 700 or so charactersSusimail: Email responses appear both truncated and repeat the first 1000 or so characters

comment:2 Changed 15 months ago by zzz

I'm a little confused because we don't store emails in tar files so I don't know how one ended up there. We store them in .txt.gz files.

Is there anything in common with the emails that get corrupted? attachments? multiple parts? Anything in the router logs when the corruption happens? You could try forwarding one of the emails to me zzz at mail.i2p and I can take a look at it.

comment:3 Changed 6 months ago by zzz

Milestone: undecided0.9.50

reproduced by zlatinb, hopefully fixable for the next release

comment:4 Changed 6 months ago by zzz

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.