Opened 3 weeks ago

Closed 3 weeks ago

#2778 closed defect (fixed)

Exception in thread "IzPack - Unpacker thread"

Reported by: bmalex Owned by: zzz
Priority: blocker Milestone: 0.9.48
Component: installer Version: 0.9.47
Keywords: Cc:
Parent Tickets: #2764 Sensitive: no

Description

This same exact thing happens on my computer and I get this in the console:

$ java -jar install.jar
Command line arguments:
Cannot find named resource: 'packsLang.xml' AND 'packsLang.xml_ron'
====================
Installation started
Framework: 5.1.3-84aaf (IzPack)
Platform: windows,version=10.0,arch=x64,symbolicName=WINDOWS_10,javaVersion=14.0.1
Installation finished
Exception in thread "IzPack - Unpacker thread" java.lang.NoClassDefFoundError: java/util/jar/Pack200
        at com.izforge.izpack.installer.unpacker.Pack200FileUnpacker.createPack200Unpacker(Pack200FileUnpacker.java:90)
        at com.izforge.izpack.installer.unpacker.Pack200FileUnpacker.unpack(Pack200FileUnpacker.java:76)
        at com.izforge.izpack.installer.unpacker.UnpackerBase.extract(UnpackerBase.java:673)
        at com.izforge.izpack.installer.unpacker.UnpackerBase.unpack(UnpackerBase.java:627)
        at com.izforge.izpack.installer.unpacker.UnpackerBase.unpack(UnpackerBase.java:528)
        at com.izforge.izpack.installer.unpacker.UnpackerBase.unpack(UnpackerBase.java:475)
        at com.izforge.izpack.installer.unpacker.UnpackerBase.unpack(UnpackerBase.java:299)
        at com.izforge.izpack.installer.unpacker.UnpackerBase.run(UnpackerBase.java:241)
        at java.base/java.lang.Thread.run(Thread.java:832)
Caused by: java.lang.ClassNotFoundException: java.util.jar.Pack200
        at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:602)
        at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)
        ... 9 more

Subtickets

Change History (2)

comment:1 Changed 3 weeks ago by zzz

Milestone: undecided0.9.48
Owner: set to zzz
Priority: majorblocker
Status: newaccepted

Thank you!
We need to disable pack200 in the installer, as it was removed in Java 14.
Workaround is to use Java 11.

comment:2 Changed 3 weeks ago by zzz

Resolution: fixed
Status: acceptedclosed

In 7190927753fb5b08a0ea03d1eaf3b8ec32e746b7 to be 0.9.47-7
OP in parent #2764 reports Java 8, so unless that's wrong, unfortunately not a fix for that ticket.

Note: See TracTickets for help on using tickets.