Opened 9 years ago

Closed 9 years ago

#341 closed defect (fixed)

Various error logs (Pipe closed, streaming ConnnectionPacketHandler, SOCKS IRC, I2CP)

Reported by: DISABLED Owned by: zzz
Priority: minor Milestone: 0.8.3
Component: api/i2cp Version: 0.8.1
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I2P version: 0.8.1-13
Java version: Sun Microsystems Inc. 1.6.0_18 (OpenJDK Runtime Environment 1.6.0_18-b18)
Platform: Linux amd64 2.6.32-26-generic
Processor: uninitialized (athlon64)
Jbigi: Locally optimized native BigInteger? library loaded from the library path
Encoding: UTF-8

# 02:40:04.177 FEHLER [tBuilder10.4] tunnel.socks.I2PSOCKSIRCTunnel: Error from SOCKS connection

net.i2p.i2ptunnel.socks.SOCKSException: Error connecting: java.net.NoRouteToHostException?: Connection timed out
at net.i2p.i2ptunnel.socks.SOCKS5Server.getDestinationI2PSocket(SOCKS5Server.java:429)
at net.i2p.i2ptunnel.socks.I2PSOCKSIRCTunnel.clientConnectionRun(I2PSOCKSIRCTunnel.java:52)
at net.i2p.i2ptunnel.I2PTunnelClientBase$TunnelConnectionBuilder?.run(I2PTunnelClientBase.java:724)
at java.lang.Thread.run(Thread.java:636)
at net.i2p.util.I2PThread.run(I2PThread.java:77)

# 01:36:25.771 FEHLER [t Writer 260] net.i2p.client.I2PSessionImpl2: [12507]: Error occurred: Error writing out the message

java.io.IOException: Pipe closed
at java.io.PipedInputStream?.checkStateForReceive(PipedInputStream?.java:261)
at java.io.PipedInputStream?.receive(PipedInputStream?.java:202)
at java.io.PipedOutputStream?.write(PipedOutputStream?.java:122)
at net.i2p.data.DataHelper?.writeLong(DataHelper?.java:477)
at net.i2p.data.i2cp.I2CPMessageImpl.writeMessage(I2CPMessageImpl.java:107)
at net.i2p.client.ClientWriterRunner?.run(ClientWriterRunner?.java:69)
at java.lang.Thread.run(Thread.java:636)
at net.i2p.util.I2PThread.run(I2PThread.java:77)

# 01:23:03.738 FEHLER [t Writer 249] net.i2p.client.I2PSessionImpl2: [12506]: Error occurred: Error writing out the message

java.io.IOException: Pipe closed
at java.io.PipedInputStream?.checkStateForReceive(PipedInputStream?.java:261)
at java.io.PipedInputStream?.receive(PipedInputStream?.java:202)
at java.io.PipedOutputStream?.write(PipedOutputStream?.java:122)
at net.i2p.data.DataHelper?.writeLong(DataHelper?.java:477)
at net.i2p.data.i2cp.I2CPMessageImpl.writeMessage(I2CPMessageImpl.java:107)
at net.i2p.client.ClientWriterRunner?.run(ClientWriterRunner?.java:69)
at java.lang.Thread.run(Thread.java:636)
at net.i2p.util.I2PThread.run(I2PThread.java:77)

# 23:29:08.762 FEHLER [P Reader 435] ent.ClientMessageEventListener?: Error occurred

net.i2p.data.i2cp.I2CPMessageException: Unable to load the message data
at net.i2p.data.i2cp.DestroySessionMessage?.doReadMessage(DestroySessionMessage?.java:46)
at net.i2p.data.i2cp.I2CPMessageImpl.readMessage(I2CPMessageImpl.java:74)
at net.i2p.data.i2cp.I2CPMessageHandler.readMessage(I2CPMessageHandler.java:45)
at net.i2p.data.i2cp.I2CPMessageReader$I2CPMessageReaderRunner.run(I2CPMessageReader.java:153)
at java.lang.Thread.run(Thread.java:636)
at net.i2p.util.I2PThread.run(I2PThread.java:77)
Caused by: net.i2p.data.DataFormatException?: Not enough bytes for the field
at net.i2p.data.DataHelper?.readLong(DataHelper?.java:440)
at net.i2p.data.i2cp.SessionId?.readBytes(SessionId?.java:41)
at net.i2p.data.i2cp.DestroySessionMessage?.doReadMessage(DestroySessionMessage?.java:44)
… 5 more

# 23:29:08.760 FEHLER [t Writer 218] net.i2p.client.I2PSessionImpl2: [12501]: Error occurred: Error writing out the message

java.io.IOException: Pipe closed
at java.io.PipedInputStream?.checkStateForReceive(PipedInputStream?.java:261)
at java.io.PipedInputStream?.receive(PipedInputStream?.java:227)
at java.io.PipedOutputStream?.write(PipedOutputStream?.java:149)
at java.io.OutputStream?.write(OutputStream?.java:75)
at net.i2p.data.i2cp.I2CPMessageImpl.writeMessage(I2CPMessageImpl.java:112)
at net.i2p.client.ClientWriterRunner?.run(ClientWriterRunner?.java:69)
at java.lang.Thread.run(Thread.java:636)
at net.i2p.util.I2PThread.run(I2PThread.java:77)

# 23:17:55.648 FEHLER [P Reader 421] ent.ClientMessageEventListener?: Error occurred

net.i2p.data.i2cp.I2CPMessageException: Unable to load the message data
at net.i2p.data.i2cp.DestroySessionMessage?.doReadMessage(DestroySessionMessage?.java:46)
at net.i2p.data.i2cp.I2CPMessageImpl.readMessage(I2CPMessageImpl.java:74)
at net.i2p.data.i2cp.I2CPMessageHandler.readMessage(I2CPMessageHandler.java:45)
at net.i2p.data.i2cp.I2CPMessageReader$I2CPMessageReaderRunner.run(I2CPMessageReader.java:153)
at java.lang.Thread.run(Thread.java:636)
at net.i2p.util.I2PThread.run(I2PThread.java:77)
Caused by: net.i2p.data.DataFormatException?: Not enough bytes for the field
at net.i2p.data.DataHelper?.readLong(DataHelper?.java:440)
at net.i2p.data.i2cp.SessionId?.readBytes(SessionId?.java:41)
at net.i2p.data.i2cp.DestroySessionMessage?.doReadMessage(DestroySessionMessage?.java:44)
… 5 more

# 23:17:55.647 FEHLER [t Writer 211] net.i2p.client.I2PSessionImpl2: [12500]: Error occurred: Error writing out the message

java.io.IOException: Pipe closed
at java.io.PipedInputStream?.checkStateForReceive(PipedInputStream?.java:261)
at java.io.PipedInputStream?.receive(PipedInputStream?.java:227)
at java.io.PipedOutputStream?.write(PipedOutputStream?.java:149)
at java.io.OutputStream?.write(OutputStream?.java:75)
at net.i2p.data.i2cp.I2CPMessageImpl.writeMessage(I2CPMessageImpl.java:112)
at net.i2p.client.ClientWriterRunner?.run(ClientWriterRunner?.java:69)
at java.lang.Thread.run(Thread.java:636)
at net.i2p.util.I2PThread.run(I2PThread.java:77)

# 22:43:37.528 FEHLER [otifier n2A5] eaming.ConnectionPacketHandler?: Packet does NOT verify: 50vJaQ==4m3vTA==: #1 CLOSE DELAY 5000 MS 1730 SIG ACK 0 on [Connection 50vJaQ==/ma011g== from L7KM up 10m wsize: 3 cwin: 6 rtt: 8000 rto: 12000 unacked out: 0 unacked in: 0 reset sent 4m ago reset received 4m ago sent: 1 rcvd: 1 maxWin 128 MTU 1730]
# 22:43:37.528 FEHLER [otifier n2A5] eaming.ConnectionPacketHandler?: Packet received with the wrong reply stream id: [Connection 50vJaQ==/ma011g== from L7KM up 10m wsize: 3 cwin: 6 rtt: 8000 rto: 12000 unacked out: 0 unacked in: 0 reset sent 4m ago reset received 4m ago sent: 1 rcvd: 1 maxWin 128 MTU 1730] / 50vJaQ==4m3vTA==: #1 CLOSE DELAY 5000 MS 1730 SIG ACK 0
# 22:42:52.285 FEHLER [otifier n2A5] eaming.ConnectionPacketHandler?: Packet does NOT verify: 50vJaQ==4m3vTA==: #1 CLOSE DELAY 4000 MS 1730 SIG ACK 0 on [Connection 50vJaQ==/ma011g== from L7KM up 10m wsize: 3 cwin: 6 rtt: 8000 rto: 12000 unacked out: 0 unacked in: 0 reset sent 4m ago reset received 4m ago sent: 1 rcvd: 1 maxWin 128 MTU 1730]
# 22:42:52.285 FEHLER [otifier n2A5] eaming.ConnectionPacketHandler?: Packet received with the wrong reply stream id: [Connection 50vJaQ==/ma011g== from L7KM up 10m wsize: 3 cwin: 6 rtt: 8000 rto: 12000 unacked out: 0 unacked in: 0 reset sent 4m ago reset received 4m ago sent: 1 rcvd: 1 maxWin 128 MTU 1730] / 50vJaQ==4m3vTA==: #1 CLOSE DELAY 4000 MS 1730 SIG ACK 0
# 22:42:07.354 FEHLER [otifier n2A5] eaming.ConnectionPacketHandler?: Packet does NOT verify: 50vJaQ==4m3vTA==: #1 CLOSE DELAY 3000 MS 1730 SIG ACK 0 on [Connection 50vJaQ==/ma011g== from L7KM up 9m wsize: 3 cwin: 6 rtt: 8000 rto: 12000 unacked out: 0 unacked in: 0 reset sent 3m ago reset received 3m ago sent: 1 rcvd: 1 maxWin 128 MTU 1730]
# 22:42:07.354 FEHLER [otifier n2A5] eaming.ConnectionPacketHandler?: Packet received with the wrong reply stream id: [Connection 50vJaQ==/ma011g== from L7KM up 9m wsize: 3 cwin: 6 rtt: 8000 rto: 12000 unacked out: 0 unacked in: 0 reset sent 3m ago reset received 3m ago sent: 1 rcvd: 1 maxWin 128 MTU 1730] / 50vJaQ==4m3vTA==: #1 CLOSE DELAY 3000 MS 1730 SIG ACK 0
# 22:41:22.231 FEHLER [otifier n2A5] eaming.ConnectionPacketHandler?: Packet does NOT verify: 50vJaQ==4m3vTA==: #1 CLOSE DELAY 2000 MS 1730 SIG ACK 0 on [Connection 50vJaQ==/ma011g== from L7KM up 8m wsize: 3 cwin: 6 rtt: 8000 rto: 12000 unacked out: 0 unacked in: 0 reset sent 158s ago reset received 158s ago sent: 1 rcvd: 1 maxWin 128 MTU 1730]
# 22:41:22.231 FEHLER [otifier n2A5] eaming.ConnectionPacketHandler?: Packet received with the wrong reply stream id: [Connection 50vJaQ==/ma011g== from L7KM up 8m wsize: 3 cwin: 6 rtt: 8000 rto: 12000 unacked out: 0 unacked in: 0 reset sent 158s ago reset received 158s ago sent: 1 rcvd: 1 maxWin 128 MTU 1730] / 50vJaQ==4m3vTA==: #1 CLOSE DELAY 2000 MS 1730 SIG ACK 0
# 22:40:58.450 FEHLER [otifier n2A5] eaming.ConnectionPacketHandler?: Packet does NOT verify: 50vJaQ==4m3vTA==: #1 CLOSE DELAY 1000 MS 1730 SIG ACK 0 on [Connection 50vJaQ==/ma011g== from L7KM up 8m wsize: 3 cwin: 6 rtt: 8000 rto: 12000 unacked out: 0 unacked in: 0 reset sent 134s ago reset received 134s ago sent: 1 rcvd: 1 maxWin 128 MTU 1730]
# 22:40:58.450 FEHLER [otifier n2A5] eaming.ConnectionPacketHandler?: Packet received with the wrong reply stream id: [Connection 50vJaQ==/ma011g== from L7KM up 8m wsize: 3 cwin: 6 rtt: 8000 rto: 12000 unacked out: 0 unacked in: 0 reset sent 134s ago reset received 134s ago sent: 1 rcvd: 1 maxWin 128 MTU 1730] / 50vJaQ==4m3vTA==: #1 CLOSE DELAY 1000 MS 1730 SIG ACK 0
# 22:40:46.581 FEHLER [otifier n2A5] eaming.ConnectionPacketHandler?: Packet does NOT verify: 50vJaQ==4m3vTA==: #1 CLOSE DELAY 0 SIG ACK 0 on [Connection 50vJaQ==/ma011g== from L7KM up 7m wsize: 3 cwin: 6 rtt: 8000 rto: 12000 unacked out: 0 unacked in: 0 reset sent 122s ago reset received 122s ago sent: 1 rcvd: 1 maxWin 128 MTU 1730]
# 22:40:46.581 FEHLER [otifier n2A5] eaming.ConnectionPacketHandler?: Packet received with the wrong reply stream id: [Connection 50vJaQ==/ma011g== from L7KM up 7m wsize: 3 cwin: 6 rtt: 8000 rto: 12000 unacked out: 0 unacked in: 0 reset sent 122s ago reset received 122s ago sent: 1 rcvd: 1 maxWin 128 MTU 1730] / 50vJaQ==4m3vTA==: #1 CLOSE DELAY 0 SIG ACK 0
# 21:51:02.454 FEHLER [t Writer 181] net.i2p.client.I2PSessionImpl2: [12497]: Error occurred: Error writing out the message

java.io.IOException: Pipe closed
at java.io.PipedInputStream?.checkStateForReceive(PipedInputStream?.java:261)
at java.io.PipedInputStream?.receive(PipedInputStream?.java:202)
at java.io.PipedOutputStream?.write(PipedOutputStream?.java:122)
at net.i2p.data.DataHelper?.writeLong(DataHelper?.java:477)
at net.i2p.data.i2cp.I2CPMessageImpl.writeMessage(I2CPMessageImpl.java:107)
at net.i2p.client.ClientWriterRunner?.run(ClientWriterRunner?.java:69)
at java.lang.Thread.run(Thread.java:636)
at net.i2p.util.I2PThread.run(I2PThread.java:77)

Subtickets

Change History (4)

comment:1 Changed 9 years ago by zzz

Component: api/datastreaming
Milestone: 0.8.2
Owner: set to zzz
Status: newassigned

Thanks for the report

I won't respond in detail here to several different types of errors… most are covered in other tickets, and most I'm working on turning into warnings.

I'll mark the category as streaming since the ConnectionPacketHandler? errors aren't covered in other tickets.

Do any of these logs correspond with a visible problem that you saw?

comment:2 Changed 9 years ago by zzz

Summary: error logsVarious error logs (Pipe closed, streaming ConnnectionPacketHandler, SOCKS IRC, I2CP)

comment:3 Changed 9 years ago by zzz

Component: streamingapi/i2cp
Milestone: 0.8.20.8.3
Status: assignedaccepted

Pipe closed and streaming CPH errors changed to warnings in 0.8.1-17.
ClientMessageEventListener? still to be dealt with. Changing component to I2CP.

comment:4 Changed 9 years ago by zzz

Resolution: fixed
Status: acceptedclosed

should be fixed in 0.8.3.

Note: See TracTickets for help on using tickets.