Opened 9 years ago

Closed 9 years ago

#352 closed defect (fixed)

completed downloads file not found exception

Reported by: DISABLED Owned by: zzz
Priority: minor Milestone: 0.8.3
Component: apps/i2psnark Version: 0.8
Keywords: Cc:
Parent Tickets: Sensitive: no

Description (last modified by zzz)

I2P version: 0.8-10
Java version: Sun Microsystems Inc. 1.6.0_20 (Java™ SE Runtime Environment 1.6.0_20-b02)
Platform: Linux amd64 2.6.28-19-generic
Processor: uninitialized (athlon64)
Jbigi: Locally optimized native BigInteger? library loaded from the library path
Encoding: UTF-8

2010/12/08 00:09:41 | java.io.FileNotFoundException?: /home/xyz/.i2p/i2psnark/Le.Mac.FRENCH.DVDRip.XviD-AYMO.By.Hadopix.avi.torrent (No such file or directory)
2010/12/08 00:09:41 | at java.io.FileOutputStream?.open(Native Method)
2010/12/08 00:09:41 | at java.io.FileOutputStream?.<init>(FileOutputStream?.java:179)
2010/12/08 00:09:41 | at java.io.FileOutputStream?.<init>(FileOutputStream?.java:131)
2010/12/08 00:09:41 | at net.i2p.util.FileUtil?.copy(FileUtil?.java:364)
2010/12/08 00:09:41 | at net.i2p.util.FileUtil?.copy(FileUtil?.java:344)
2010/12/08 00:09:41 | at org.klomp.snark.web.I2PSnarkServlet$FetchAndAdd?.run(I2PSnarkServlet.java:1625)
2010/12/08 00:09:41 | at java.lang.Thread.run(Thread.java:619)
2010/12/08 00:09:41 | at net.i2p.util.I2PThread.run(I2PThread.java:77)

2010/12/08 00:09:43 | java.io.FileNotFoundException?: /home/xyz/.i2p/i2psnark/cablegate-201012072002.7z.torrent (No such file or directory)
2010/12/08 00:09:43 | at java.io.FileOutputStream?.open(Native Method)
2010/12/08 00:09:43 | at java.io.FileOutputStream?.<init>(FileOutputStream?.java:179)
2010/12/08 00:09:43 | at java.io.FileOutputStream?.<init>(FileOutputStream?.java:131)
2010/12/08 00:09:43 | at net.i2p.util.FileUtil?.copy(FileUtil?.java:364)
2010/12/08 00:09:43 | at net.i2p.util.FileUtil?.copy(FileUtil?.java:344)
2010/12/08 00:09:43 | at org.klomp.snark.web.I2PSnarkServlet$FetchAndAdd?.run(I2PSnarkServlet.java:1625)
2010/12/08 00:09:43 | at java.lang.Thread.run(Thread.java:619)
2010/12/08 00:09:43 | at net.i2p.util.I2PThread.run(I2PThread.java:77)

2010/12/08 00:09:59 | java.io.FileNotFoundException?: /home/xyz/.i2p/i2psnark/Depeche Mode - 2005 Playing The Angel.torrent (No such file or directory)
2010/12/08 00:09:59 | at java.io.FileOutputStream?.open(Native Method)
2010/12/08 00:09:59 | at java.io.FileOutputStream?.<init>(FileOutputStream?.java:179)
2010/12/08 00:09:59 | at java.io.FileOutputStream?.<init>(FileOutputStream?.java:131)
2010/12/08 00:09:59 | at net.i2p.util.FileUtil?.copy(FileUtil?.java:364)
2010/12/08 00:09:59 | at net.i2p.util.FileUtil?.copy(FileUtil?.java:344)
2010/12/08 00:09:59 | at org.klomp.snark.web.I2PSnarkServlet$FetchAndAdd?.run(I2PSnarkServlet.java:1625)
2010/12/08 00:09:59 | at java.lang.Thread.run(Thread.java:619)
2010/12/08 00:09:59 | at net.i2p.util.I2PThread.run(I2PThread.java:77)

2 of those I'm seeding, one still downloading

Subtickets

Change History (5)

comment:1 Changed 9 years ago by zzz

Description: modified (diff)
Milestone: 0.8.3
Owner: set to zzz
Status: newassigned

I don't understand what's happening here.

FetchAndAdd? is only started from the snark 'Add Torrent' button. If you were already running these torrents, FetchAndAdd? shouldn't be called. If you added each torrent with 'Add Torrent', it should work. But I don't see how you could add 3 torrents in 18 seconds.

Did this happen at startup, or when you clicked some button in snark? Can you reproduce it?

While investigating this, I did see the need for better error detection and logging in FetchAndAdd?, that will be in 0.8.2.

comment:2 Changed 9 years ago by DISABLED

This happened about 15 minutes after startup of i2p router. Those 3 torrents I added in this session, but i2psnark itself never complained nad showed them downloading ok and even seeding. I just stumbled over it when doing a routine check of the logs.
have not restarted since then.

comment:3 Changed 9 years ago by zzz

Status: assignedaccepted

Error detection and logging improvements in 0.8.1-36-rc.

I still don't fully understand what happened so I'm leaving this ticket open for now.

comment:4 Changed 9 years ago by DISABLED

have not seen this error again on -37rc

comment:5 Changed 9 years ago by zzz

Resolution: fixed
Status: acceptedclosed

closing, either it was fixed or isn't reproducible, please reopen ticket if it recurs.

Note: See TracTickets for help on using tickets.