Opened 9 years ago

Closed 8 years ago

#353 closed defect (not a bug)

no listener found

Reported by: DISABLED Owned by: zzz
Priority: minor Milestone: 0.8.2
Component: api/i2cp Version: 0.8
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I2P version: 0.8-10
Java version: Sun Microsystems Inc. 1.6.0_20 (Java™ SE Runtime Environment 1.6.0_20-b02)
Platform: Linux amd64 2.6.28-19-generic
Processor: uninitialized (athlon64)
Jbigi: Locally optimized native BigInteger? library loaded from the library path
Encoding: UTF-8

# 12:33:20.421 ERROR [otifier qw0C] client.I2PSessionDemultiplexer: No listener found for proto: 0 port: 0msg id: 30181 from pool of 0 listeners
# 12:33:17.650 ERROR [otifier qw0C] client.I2PSessionDemultiplexer: No listener found for proto: 0 port: 0msg id: 30124 from pool of 0 listeners
# 12:33:17.428 ERROR [otifier qw0C] client.I2PSessionDemultiplexer: No listener found for proto: 0 port: 0msg id: 30122 from pool of 0 listeners paste.

Subtickets

Change History (5)

comment:1 Changed 9 years ago by zzz

Milestone: 0.8.2
Owner: set to zzz
Status: newaccepted

I think this is just an error at startup/shutdown of a tunnel, where data came in but there was no client anymore to take it.

Can you confirm that? what was happening at the time?

I'll change it to a warning in 0.8.1-36-rc.

comment:2 Changed 9 years ago by DISABLED

I had stopped the app (a plugin) but the tunnels had remained open even hours after that

comment:3 Changed 9 years ago by zzz

ok, so that was a 'normal' error, now changed to a warning.

The tunnels remaining open is a problem, of course… quite separate from the log errors.

What plugin and plugin version?

comment:4 Changed 9 years ago by DISABLED

it was i2p-bote 0.2.4, I had stopped it in order to upgrade to 0.2.5 which I could not due to verification of key failed

comment:5 Changed 8 years ago by zzz

Component: router/generalapi/i2cp
Resolution: not a bug
Status: acceptedclosed

ok, that's a legitimate error then, a message came in but the plugin had stopped listening. Closing the ticket.

Note: See TracTickets for help on using tickets.