Opened 8 years ago

Closed 8 years ago

#391 closed defect (fixed)

snark: leech not progressing

Reported by: guest Owned by: zzz
Priority: minor Milestone: 0.8.3
Component: apps/i2psnark Version: 0.8.2
Keywords: Cc:
Parent Tickets:

Description

As of now I have encountered the problem twice. Downloads are starting well an running. After some time (no restart of i2p), the amount of downloaded data stalls (as displayed). There still are working peers, to which I am connected and snark shows an eta and a download speed. This seems to effect only single torrent (other leeches run prefectly in parallel).

After deleting the torrent and data files and restarting, everything seems to be working fine.

I am useing 0.8.2

Subtickets

Change History (4)

comment:1 Changed 8 years ago by zzz

  • Component changed from unspecified to apps/i2psnark
  • Milestone set to 0.8.3
  • Owner set to zzz
  • Status changed from new to accepted

Thanks. Something similar was reported earlier on forum.i2p. I was never able to reproduce it here, but I saw some problems in the code that may have been the cause, and I fixed them for 0.8.3. So maybe a 50/50 chance it's already fixed.

Does a router restart (without deleting the torrent and data files) fix the problem?

If it happens again please take a thread dump (button on /configservice.jsp) and email it to me zzz@….

comment:2 Changed 8 years ago by guest

I like to append that the clients did not freeze at once, they freeze slowly torrent after torrent. It's like a OOM in the coordinators not in the snarkmanager. A restart of all torrents should be enough to reawake them. but I never saw a reawoken client with same destination I must admit. Those that come back got allways a new destination. At first they stay for hours with the old known bitfield and fallback behind all other and didn't share anything in both ways. You can connect and they show the bitfield. Next harder step is that they did not show the bitfield like it should be than they fallout by all torrents and disappearing from the tracker but when you have the valid destination than you could still connecting with them and they show a empty bitfield for each torrent. Some shown a different behaviour, they are listed on the tracker over hours but you can not connect with them but proberly this could be also a sideeffect of the limited connections for the amount of peers and the frozen state.

  • bs

comment:3 Changed 8 years ago by guest

proberly one thing to append too:
All clients that I'd seen are listed in a lot of torrents.
###---
My lucky guess is a problem with the I2PThread class. Special those threads that use SimpleTimerEvent? had made some problems in the past and were replaced by a seperated Thread class in the client I'm using usually.

  • bs

comment:4 Changed 8 years ago by zzz

  • Resolution set to fixed
  • Status changed from accepted to closed

Hopefully fixed in 0.8.3? If it happens in 0.8.3 please reopen ticket and attach a thread dump or email it to me.

Note: See TracTickets for help on using tickets.