Opened 8 years ago

Closed 8 years ago

#396 closed defect (fixed)

Unable to login to trac via i2p

Reported by: killyourtv Owned by: welterde
Priority: major Milestone: 0.8.5
Component: www/i2p Version: 0.8.3
Keywords: trac, login Cc: killyourtv@…
Parent Tickets:

Description

A user, on IRC (let's call him user) experienced difficulty logging into http://trac.i2p2.i2p trac to file a bug (which has been taken care of with ticket:394).

Another user, RN also had the same issues with logging in. Finally, I also had the same problems.

My router environment:

I2P version: 0.8.3-0
Java version: Sun Microsystems Inc. 1.6.0_22 (Java(TM) SE Runtime Environment 1.6.0_22-b04)
Platform: Linux amd64 2.6.36-zen1
Processor: uninitialized (athlon64)
Jbigi: Optimized native BigInteger library 'libjbigi-linux-athlon64.so' loaded from resource
Encoding: UTF-8


I cannot speak for the others, but I have tried

  • clearing my cache
  • clearing my cookies
  • starting Firefox in safe mode
  • going directly through the i2p proxy at http://localhost:4444 without using privoxy, torbutton, etc.
  • creating a new brand-spankin' new browser profile

Hey! If you can't log in, how did you file this bug?

I came in through TOR.

Subtickets

Change History (12)

comment:1 Changed 8 years ago by sponge

I had the same problem... I simply deleted ALL cookies and it now works... this was with seamonkey browser :-)

comment:2 Changed 8 years ago by zzz

  • Owner set to welterde
  • Status changed from new to assigned

Confirmed that deleting the cookies for trac.i2p2.i2p fixes the problem, temporarily.

Logging out and attempting to log back in, the problem returns.

Reverted back to 0.8.1 on my side does not fix the problem.

Various people have looked at the recent i2p changes, and looked at the headers with wireshark and logging, to no avail. I've also studied RFC 2617 (digest auth) for clues, no luck. More discussion on the issue at http://zzz.i2p/topics/820 .

The problem started for me some 15 days after welt last updated his router, so it may not be an I2P problem at all?

Assigning to welterde.

comment:3 Changed 8 years ago by zzz

  • Component changed from unspecified to apps/i2ptunnel
  • Owner changed from welterde to Mathiasdm
  • Priority changed from major to blocker

This is caused by the change introduced in 0.8.2 to filter headers in the server-to-client direction. The headers are stored in a Properties map, so additional lines with the same key (for example multiple Set-Cookie lines) are lost, and only one remains. Multiple Set-Cookie lines are allowed. The code in I2PTunnelHTTPServer must be reworked to filter what needs to be filtered, without losing any other lines.

comment:4 Changed 8 years ago by Mathiasdm

This bug should be fixed now, by using a multimap. Once welterde updates trac, it can be confirmed.

comment:5 Changed 8 years ago by Mathiasdm

  • Status changed from assigned to accepted

comment:6 Changed 8 years ago by Mathiasdm

Example of the bug to test on:
Set-Cookie: trac_auth=random_number; Path=/

Set-Cookie: trac_session=random_number; expires=Wed, 09-Feb-2011 22:00:00 GMT; Path=/

comment:7 Changed 8 years ago by Mathiasdm

  • Resolution set to fixed
  • Status changed from accepted to closed

Tests have been added in mtn and work.

comment:8 Changed 8 years ago by zzz

  • Resolution fixed deleted
  • Status changed from closed to reopened

reopening and reassigning back to welterde to update the router

comment:9 Changed 8 years ago by zzz

  • Component changed from apps/i2ptunnel to www
  • Owner changed from Mathiasdm to welterde
  • Priority changed from blocker to major
  • Status changed from reopened to assigned

comment:10 Changed 8 years ago by echelon

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:11 Changed 8 years ago by zzz

  • Milestone changed from 0.8.4 to 0.8.5
  • Resolution fixed deleted
  • Status changed from closed to reopened

I'm still having problems and so are others, even after welt updated the router.

comment:12 Changed 8 years ago by killyourtv

  • Cc killyourtv@… added
  • Resolution set to fixed
  • Status changed from reopened to closed

It seems that this has been resolved with the update to 0.8.5.

Note: See TracTickets for help on using tickets.