Opened 9 years ago

Closed 9 years ago

#416 closed defect (fixed)

cannot install or update plugins

Reported by: DISABLED Owned by: zzz
Priority: blocker Milestone: 0.8.4
Component: apps/plugins Version: 0.8.3
Keywords: plugins Cc:
Parent Tickets: Sensitive: no

Description

the message is: "Plugin signature verification of http://tjgidoycrw6s3guetge3kvrvynppqjmvqsosmtbmgqasa6vmsf6a.b32.i2p/i2pbote.xpi2p failed"

I tired several times in order to exclude the possibility of a corrupt download.

router version: 0.8.3-13

Subtickets

Change History (3)

comment:1 Changed 9 years ago by zzz

Component: router/generalapps/plugins
Owner: set to zzz
Status: newaccepted

Was this an update or not? Was a previous i2pbote plugin already installed?

comment:2 Changed 9 years ago by zzz

Priority: criticalblocker

reproduced here, chasing it now

comment:3 Changed 9 years ago by zzz

Resolution: fixed
Status: acceptedclosed

This only happened if router.config specified router.trustedUpdateKeys (which happens if the user has previously changed and saved the update config on /configupdate), AND the plugin signer is already trusted (i.e. HungryHobo? and zzz). The workaround is to remove router.trustedUpdateKeys on /configadvanced, save, and restart.

Fixed in 0.8.3-16-rc.

Note: See TracTickets for help on using tickets.