Opened 8 years ago

Closed 8 years ago

#430 closed defect (fixed)

Error 500: /logs Internal Server Error

Reported by: DISABLED Owned by: zzz
Priority: major Milestone: 0.8.5
Component: apps/console Version: 0.8.4
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I2P version: 0.8.4-4
Java version: Sun Microsystems Inc. 1.6.0_24 (Java™ SE Runtime Environment 1.6.0_24-b07)
Platform: Linux amd64 2.6.35
Processor: uninitialized (athlon64)
Jbigi: Optimized native BigInteger? library 'libjbigi-linux-athlon64.so' loaded from resource
Encoding: UTF-8

When opening http://127.0.0.1:7657/logs I get:

Error Details

Error 500: /logs Internal Server Error 

java.lang.NullPointerException
     at net.i2p.router.web.jsp.logs_jsp._jspService(logs_jsp.java:259)
     at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)
     at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
     at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:428)
     at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:473)
     at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:568)
     at net.i2p.router.web.LocaleWebAppHandler.handle(LocaleWebAppHandler.java:90)
     at org.mortbay.http.HttpContext.handle(HttpContext.java:1535)
     at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.java:633)
     at org.mortbay.http.HttpContext.handle(HttpContext.java:1487)
     at org.mortbay.http.HttpServer.service(HttpServer.java:909)
     at org.mortbay.http.HttpConnection.service(HttpConnection.java:820)
     at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:986)
     at org.mortbay.http.HttpConnection.handle(HttpConnection.java:837)
     at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:245)
     at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:357)
     at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)

Subtickets

Change History (2)

comment:1 Changed 8 years ago by zzz

Component: router/generalapps/console
Owner: set to zzz
Status: newaccepted

Good catch, thanks. Only happens with text browsers, caused by recent text browser changes. Will fix shortly.

comment:2 Changed 8 years ago by zzz

Resolution: fixed
Status: acceptedclosed

Fixed in 0.8.4-5. Thanks for the report.

Note: See TracTickets for help on using tickets.