Opened 9 years ago

Closed 8 years ago

#433 closed defect (fixed)

problem with magnets

Reported by: DISABLED Owned by: zzz
Priority: minor Milestone: 0.9
Component: apps/i2psnark Version: 0.8.4
Keywords: Cc:
Parent Tickets: Sensitive: no

Description (last modified by zzz)

I2P version: 0.8.4-5
Java version: Sun Microsystems Inc. 1.6.0_20 (OpenJDK Runtime Environment 1.6.0_20-b20)
Platform: Linux amd64 2.6.35-27-generic
Processor: uninitialized (athlon64)
Jbigi: Locally optimized native BigInteger? library loaded from the library path
Encoding: UTF-8

Torrent with this info hash is already running: pink floyd - atom heart mother suite.mp3
Starting up torrent pink floyd - atom heart mother suite.mp3
Metainfo received for Magnet dd6866fbc2ecbec579476065ac7c32b86bbcdbb6
Starting up torrent Magnet dd6866fbc2ecbec579476065ac7c32b86bbcdbb6
Adding Magnet dd6866fbc2ecbec579476065ac7c32b86bbcdbb6

missing added confirmation when adding a magnet link and spamming status bar with the error message as seen above.

Subtickets

Change History (6)

comment:1 Changed 9 years ago by zzz

Description: modified (diff)
Owner: set to zzz
Priority: trivialminor
Status: newaccepted

comment:2 Changed 9 years ago by zzz

Milestone: 0.8.50.8.6

I can't reproduce this here but I'll continue to try and to look for locking issues.

comment:3 Changed 8 years ago by zzz

Milestone: 0.8.60.8.9

see also #504

comment:4 Changed 8 years ago by str4d

Milestone: 0.8.120.8.14

comment:5 Changed 8 years ago by zzz

Milestone: 0.8.140.9

comment:6 Changed 8 years ago by zzz

Resolution: fixed
Status: acceptedclosed

Caused by a symlink in the snark path and absolute vs. canonical paths in the code. Fixed in 0.8.13-21.

Note: See TracTickets for help on using tickets.